Enemy Territory gets mysterious lag (with dual-core)


(SCDS_reyalP) #101

http://wolfwiki.anime.net/index.php/Lagometer FWIW


(highbrid) #102

i’ve read thru that before but everytime it makes a lil more sense to me lol.

what i want to know is…am i consistantly not recieveing snapshots on a perfectly spread out basis, is my computer cutting these snapshots off…

or am i recieveing these snapshots and something is causeing my computer not to be able to draw the time between some of these snapshots which is showing in my framrate.

and lastly i want to know…WHAT PIECE OF HARDWARE IN MY COMPUTER IS DOING THIS???

can video cards mess up in this way causing problems like this w/o showing it on the fps counter? who’s stealing my fps???


(AKA Sneaky) #103

I use

/cl_maxpackets 100
/com_maxfps 100
/cl_packetdup 1
/rate 50000

Also, instead of forcing 32 bit on graphics i just use default setting. My game runs fine on a full 64 players server in France (90-110 ping avg), and i’m in Quebec. I’m used to play in Toronto and New York (20-40 ping avg) but it seems all the good server i used to play with are gone or their half empty, i love playing etpro. :frowning:

I have:

C2d e6400
PNY 6800gs AGP
2gb OCZ pc2-5400

Also your computer might be infested with spyware and other kind of malware, trojan and everything that might affect your connection speed.

Anyhoo this works for me


(AKA Sneaky) #104

Maybe it’s your router. or firewall, network card, or anything between the internet and your network card (cables?).


(zig-zag) #105

One more thing to check, I haven’t read the whole thread, but if you have an nVidia card, there’s a setting for the driver “Threaded optimization”
Maybe turning that on/off might make a diff. Just a thought.


(highbrid) #106

hi zig-zag :slight_smile: … surprised i’m still having these problems?? u were there for the beginning.

the problem started with spyware…or i think.

waited to long to fix the problems as they started. first explorer started crashing in game. took a while to happen at first but slowly it took less and less games. when it did crash i’d get these random glitch’s causing the game to skip real bad every minute or so and i’d have to restart.
had to restart manually thou becuase nothing in the explorer bar/start menu worked.

then one day after i just started using the nvidia desktop manager and i was also trying out different cfg’s (or i believe this was the day) everything went to shit. bullets stoped going where my crosshair was and the constant fps skipping started and got worse and worse everyday.
(set stencil bits to 8 and maybe another cvar and know ur hardware has to support stencil bits but it was in the cfg i was tryin so i said wth…dont know if this can mess up ur vid card if it doesnt support it thou…still dont know what stenil bits are either…if someone knows let it out!)

i’ve reformatted, flashed the bios, and am now at a different house hooking it up for the first time here after a clean reformat and i still have the fps skipping problem. so if there is a virus/spyware stuck on here it can live thru flashed bios. and the only piece of hardware not hooked up when i do this is the video card cuz well…its damn big and sits right in the way of the jumpers.

wolf is also causeing runtime error’s after enough games atm but i’m thinking this has to do with playing on pubs and all the maps i have to download so i’ve been deleteing as much stuff in et as possible every few days.

i’ve also used different cables, router or no router, and new mobo which i plug the internetz directly into because the a8n32sli deluxe’s ports and drivers for these ports are pretty damn good…or should be atleast.

and again…by fps skipping i mean. about every 8 fps or so it skips 1 or 2. only shows up in the lagometer as breaks in the frames bar and i have to turn down the fps to see these.

also…i know pb has a systems file now causing packet problems for many. anybody know if this or another program run’s/scans maybe ur fps in the way of screenshots about 8 frames a second??


(NUTS!) #107

Hey guys, I’m posting here since this is very similiar to the problem I’m having for the last week or so.

Symptoms:

Lag(?) or more like a gun jam when I’m firing at someone. If FF is off then I have no problem firing at teammate but if FF is on then the same symptom as well. It’s very appearant when I’m shooting using SMG, sometime it feels like seconds before the bullets starts to fly again. Needless to say, this makes the game almost unplayable. Playing on different mods (noquarter, jaymod) doesn’t change anything.

My setup (about 2 month old)

E4300 (not overclocked)
GeForce 7900GS
2 gb ram.

I’m just guessing here, it’s something to do with how the game calculate damage, what do you guys think?

I already replaced the ram and update the video driver, this time to a 3rd party one, still no luck. I also reinstalled ET from scratch. I searched and found no spyware and I have no other programs affected.

Meanwhile, if I find a solution I’ll come back and update.

edit: Did a system restore to about 2 weeks back (quite sure I didn’t have a problem then). Made no difference… I guess I will try the Power Supply next… IM GOING INSANNNE


(alvin) #108

Weapons in E.T. have built in lag. MMG has the most. Tank, knife & K43 (scope mode only) have the least. These are not subtle differences (seems about 50-150 ms for mp40/thompson/sten. Tank seems almost zero). Everything stays in sync mostly. Only mouse input is delayed. There may be a slight delay for hitsounds (so they are heard over firing i guess).
Re-binding the fire button (to bi-nocs for instance) will bring back instant response so its only weapons. Someone might try it. It helps to tap the mouse hands off, sound off too.


(REFLEX@AKA SVEN) #109

crap nobody is finding an answer to this CRAPPY!!! its a site to find answers isnt it and nobody is giving some answers here skilled site c you


(alvin) #110

Just played TC:E and there is no lag for me either.


(murka) #111

it’s not the reason that nobody wants to give that info, its the reason that nobody is experiencing/has fixed it.


(Nail) #112

actually, with that attitude, I won’t answer, c u


(NUTS!) #113

Hey thanks for some interesting tidbit. I just found bunch of very COOL things to report!!!

I binded my mouse1 button to +zoom for binoc and found a few interesting things.

>> Yup, it even happens with Binoc, I keep my mouse button pushed down and it will zoom in-and-out WHEN ENEMY IS CLOSE BY. This does not happen if enemy is in distance.

>> Then I bind +attack (which is usually mouse1) to one of the random button on keyboard. GUESS WHAT!? I SOLVE TEH PROBLEM, no more lag when firing.

So?! It’s my mouse? But when doesn’t this happen when enemy is far away. It still might be a processor issue with how mouse input is processed.

Ok, as I typed this up, I just tried something else. I am using Logitech G5 Laser Mouse which uses SETPOINT software to allow me to assign mouse button to keys so I use the “/” key.

bind / +attack
then I assign “/” to one of the side button

Guess what, lag is gone. so for now I just have to get used using this side button (usually as the pageback button) to fire.


(Nail) #114

maybe try without logitech drivers, try ms generic mouse drivers (you can still use mouse 1 - 5), seems to me there used to be a conflict with setpoint


(NUTS!) #115

Well, I uninstalled SetPoint, no help. then I installed “HID-Compliant” mouse driver instead of the HID-Compliant G5 driver. Still no help.

Too bad SetPoint can’t reassign the mouse1 button. aRGGHH

This makes no sense what so ever.

The Binoc to mouse1 idea was great though. It allowed me to see exactly what’s going on. It’s like when I get close to an enemy I let off the button for a second. It’s like something cut in the mouse1 signal. However, keep in mind, the attack command works fine with other mouse buttons and keyboard, just the mouse1 button and only when an enemy is close.

UPDATE:

I “borrowed” an old fashioned cheap optical mouse to try it out and … guess what, it worked. Which makes even less sense… I went over to logitech’s forum and found the majority of the posts in the mouse section are about G5 problem.

Also come to think of it, this problem started sometime near when I changed my flaky Power Supple (Antec Neo430) and RMAed it. Now i’m a cheap 350W PS I have laying around. I wonder if the G5 power requirement somehow creates an issue with the high temporary power consumation when I’m in a dog fight with someone. But why isn’t other mouse button affected? I don’t know.

I’ll update this if I get an answer from Logitech or if another Power Supply solves the issue.


(alvin) #116

Ok thats a mouse lag problem. Other ppl here get connection lag. On top of all that E.T’s built-in lag can be found in the TC:E changelog :

“completely reworked ETs trigger/delay system for bullet weapons to Q3TC045 standard. Bullet weapons are now triggered instantaneously (was 50 msec delay) and semi-auto fire can be retriggerd all 100 msec (was 200 msec before)
massively reduced retrigger rate of semi-auto and pump shotguns. Semi-auto operation is now faster than pump operation.”

http://www.linux-gamers.net/modules/news/article.php?storyid=700


(Gel) #117

new computer:
6600 core2 duo
2gb geil ram
asus p5b deluxe mobo
8800gts (640mb)

no difference in delay - still present.

additional faggotry now with massive fps loss (unable to hold anything stable - fluctuates between 50 - 125 for no apparent reason given every other game like company of heroes, css, oblivion all perform fine with uber settings whilst ET runs like a pig no matter what settings i use.

Deleted ET from my machine, so I guess that means the problem has gone away :stuck_out_tongue:

TBH, I had this for waaaayyyy too long and tried hard to fix it, but I guess it just isn;t meant to be :confused:


(mortis) #118

FWIW - I have found Wolfy to be extremely sensitive to video driver versions. I’m not sure why that is, but I’ve definitely noticed some peculiarity on the same hardware with different drivers, even when other games ran fine. That said, my current system runs Wolfy perfectly with the newest drivers.

E6700 Core2 Duo @ 2.8GHz
eVGA 7600GT
2GB of DDR2 533 dual channel mode


(grizzlybear) #119

just been clocking my lads c2d6600 and ran across cpuz reporting x9 then x6 on the cpu (apparently an energy saving thing) shouldnt be a cause but may be worth checking

came across this tho
throttle
dual core xphotfix http://forum.notebookreview.com/showthread.php?t=60416

3.2 stable stock volts on air (hate kids, im on amd3200@2.6 :()


(Walking Target) #120

I had lag at first when i played ET but I did some things and now I have a normal, more reasonable ping.

the default memory of ET is 64. Hit /set com_hunkmegs “256”. This will change the memory given to ET to 256. Use the half RAM you have, so if you have 256 > 128, 512>256, 1G>512 and so on.

Next thing I did is lower the res to fast that improved my fps too lol.