Enemy Territory gets mysterious lag (with dual-core)

(Irra) #1

Hello everyone!

I’m not sure if this would be the best place to look for help but as this is the official forum of Splashdamage, I thought I could turn to you folks.

To get things started, I’m a rather long-term Enemy Territory player (played for almost the whole age of the game) who has encountered some severe problems lately with the game. I mention this just not to get a whole load of those “reinstall the game and do this + this + this to get it done” because I really don’t think I need that kind of advice.

The basic problem I’m having here is that the game, simply said, lags. And no, I’m not talking about the two traditional kind of lag types. My fps is high (very easily almost stable 125 if I want it to be that way) and the gameplay is smooth. Neither is it about the ping or any other network stuff, no matter which ping I have I still get the same “mysterious lag”, not depending on the server I’m on. Yes, my connection is good enough and has been stable, I got 4/1Mbps broadband connection if the info would help anything.

So, what kind of lag is it then? I’ll tell you, movement and all that stuff works smoothly but whenever I shoot it feels like the bullets were delayed a bit (like an extra 40-80 ms of network delay would be added in top of my ping). Overall it’s rather hard to explain completely but I guess that’s the best I can do about that.

My best guess about the cause for this lag is my processor. I got Amd Athlon 64 X2 3600+ - dualcore processor. It’s not cutting-edge but absolutely good enough to run ET with no problems. I have done loads of research about the matter and have one possible reason linked to dual-core technical details (some timing problems with the two cores when they need to work with single-core applications such as ET). I have downloaded and installed the AMD’s “Dual-core Optimizer” which should resolve some of these timing problems but with no results. As a sidenote, I’m not totally sure about the time I first started getting this lag but it must have been somewhere close the time I got myself this rig with the dual-core processor. Anyway I remember the game working fine for some time with this same rig but now I just can’t get it roll like it used to. Another two notes : I have no overclock with my system and all other games feel to be running totally normally.

Well then, just to make things more problematic, I can tell you I have tried totally every idea I have had with this thing. So far I have tried among other things these: (not in any particular order, just listing things here)

-Reinstalled the game (5-6 times)
-Downloaded the installers again to make sure no files are corrupt
-Reinstalled Windows
-Defragmented HDD (also formatted C: with the Win reinstall)
-Downloaded newest drivers for all the stuff
-Resetted bios
-Experimented with a load of different processor stuff (drivers, dual-core optimizer etc)
-Went through “all” the ET commands and settings that could affect performance
-Tried setting processor affinity settings and priority settings for ET.exe
…and a lot of other things.

So, in a nutshell I’d like to know if anyone has any ideas / solutions for my problem? And if someone here could tell their experiences with ET running at AMD dualcore processor, those would be very appreciated.

I’ll throw in the detail specs about my computer for the end:

MSI K9N Neo (Nforce 550 chipset)
AMD Athlon 64 X2 3600+ @ AM2 socket
1Gb of 553Mhz Buffalo brand DDR2 memory
Club3d Geforce 7600Gs @ Pci-e socket
80Gb Samsung
350W HEC Power supply (yes, it’s sufficient, if I had power problems, those wouldn’t appear with ET because I don’t have any with other, heavier apps)

I’ll appreciate if someone likes to use the time and effort to read this post and even possibly reply to it.

PS, sorry for my possibly clumsy English - I’m from Finland so forgive me :slight_smile:


(BondyBoy007) #2

for someone whose first language isn’t english (and even some ppl where it is), that’s a dam fine post. :smiley:

sorry I can’t help with your problem though, I’m sure someone will be along shortly . . .

(Flesh) #3

Maybe he should have posted on the official community site :evil:

(Nail) #4

Maybe he should have posted on the official community site :evil:[/quote]

For ET, this is as close to an “Official” site as you get.

Does it happen in all mods, ie: etpro, jaymod, no quarter ?

(Irra) #5

Maybe he should have posted on the official community site :evil:[/quote]

For ET, this is as close to an “Official” site as you get.

Does it happen in all mods, ie: etpro, jaymod, no quarter ?[/quote]

Etpro is the only form of ET I find myself playing. Never tried jaymod, never heard of “no quarter” but I guess I should try with Etmain to see if it’s about etpro only or the whole game. Anyway as I played TC:E (ET fullmod) I didn’t seem to notice similar lag behaviour. But I’ll try the Etmain right now, reporting back with results as soon as I have some.

(iwound) #6

Try disconnecting your internet and run around a map on your own
to see how it is.
This would confirm a hardware problem or not.

(Irra) #7

Disconnecting the net sounds like a nice idea.

Just tried ETMain (which I think is horrible, lol) and it felt like it had the same lag. Not so easy to tell for sure because Etpro has the great hitsounds which helped me to notice the problem in the first place. Again, I’ll return with some further results.

(DarkangelUK) #8

Is ET the only game you have performance issues with?

(Hewster) #9

Hi Irra,

Not sure if its related, but if I run RtCW on my core2 duo, i get
performance problems.

To fix, I start the game windowed, then open console “`” so i can use the
mouse ouside of the game, then open the task manager
(right click on task bar, and click task manager)

Then open processes within task manager, and find the game executable

Right click on the .exe, and select “set affinity”
Then select just 1 cpu.

This works for me, might be worth a shot :slight_smile:


(Irra) #10

Ok, ran a test with Etmain (Etpro refused to create a local server, gave me some error) on a map on my own and it seemed to be free of the lag. But this, I think, must be greatly effected by the fact that local server has zero ping which means the bullets hit their target with almost no delay.

Darkangel, I’m rather confident that ET is the only game having issues. Again, it’s not so easy to confirm it because of the other games do lack such a lovely thing as hitsounds but no other game gives such a laggy overall feeling with shooting. So I’d say, yes, ET is the only one.

Hewster, thanks for the nice idea but as I already mentioned somewhere in my first post, I have tried setting affinity but it has no effect.

(mortis) #11

FWIW - I run etpro on my dual core E6700 Core 2 Duo and I have no issues whatsoever, except that I had to use com_maxfps 125 to keep my FPS from causing “high FPS” wolfy issues. I never get less than 333 frames per second, and those kind of frame rates cause the Wolf:ET engine to break, get packet loss, etc. Try capping the frame rate if you aren’t already doing that. The dual core in and of itself is not the problem as my system runs it perfectly. Use the lagometer to compare your connection at various frame rate caps.

Higher frame rates increase the bandwidth consumed by Wolfy IIRC, so low rate servers might compound your issues by not being able to keep up with your client.

My computer, for your reference:

E6700 Core2 Duo 2.66 (overclocked to 2.8 GHz)
2GB dual channel DDR2-566
D975XBX Intel mainboard
EVGA 7600GT pcie video card
Seagate 320GB SATA II 16MB cache

(Irra) #12

Mortis, I have my Fps capped at 125 aswell. Even higher (200) works, but it does not effect my lag. I once tested to set the fps cap to some ridiculous numbers and I had huge lag, connection interrupted and I couldn’t even move - setting the cap lower removed it instantly. So this one ain’t about it.

Maybe it’s not the dual cores in general but the Intel / AMD axis - some resources claim that these kind of timing problems I’m possibly suffering from wouldn’t be as serious on Intel as they are on AMD. Don’t know about that, though.

(mortis) #13

I used to have a computer that was extremely sensitive to driver versions, where lag was noticeably more severe with some drivers than others. Other systems I’ve had don’t seem to lag with any drivers. I haven’t heard anyone say that their dual cores don’t run Wolfy properly, but I’ve heard lots of people say that about their drivers on certain systems. Without being able to see your lagometer and play your machine, it’s hard for me to think of any other suggestions. I think that your hardware is probably not to blame…more likely it’s something else.

My motherboard allows a “single processor core mode” if you have a similiar item in BIOS…try it to rule out the dual core as the cause.

(Irra) #14

Hmm, drivers could cause it - they have always caused me all kinds of nasty things so why not this time again.

What comes to the lagometer, I could post a screenshot of my lagometer when being in the game. From the small observing I did do, it does show rather constant, logical pattern on it (no weird spikes while shooting or stuff like that).

Double-checking my bios, although I highly doubt there’s such an item.

(BondyBoy007) #15

Maybe he should have posted on the official community site :evil:[/quote]

to which W:ET official community site are you referring?

(Sauron|EFG) #16

The SD forum may be a better place for ET tech support (at least for now), but I wouldn’t call it more “official” for ET than the forum called “Wolfenstein: Enemy Territory” hosted on a server with "enemyterritory in the URL… :slight_smile:

On topic:

(zig-zag) #17

I also have dual core (AMD 3800x2) and ET runs fine except for ETpub servers. For pub I have to set affinity to one core or it jumps back and forth from 20fps to 76 (my set max). Vanilla and Pro run fine though. Make sure you have the dual core drivers installed http://www.amd.com/us-en/Processors/TechnicalResources/0,,30_182_871_13118,00.html

(AKA Sneaky) #18

/cl_maxpackets 999


(murka) #19

maxpacets limit is 100

(Nail) #20

btw, your etpro error with self host is prolly cause you just have the pk3, not the entire etpro download