Enemy Territory gets mysterious lag (with dual-core)


but you must now my 12V line is working @ 8.19 volt when im in ETTV i get 40 frames max beacuse there are much people and it should happend anyway i have a greattt video card 8800GT dual core everything you want so hmm i dont understand it :)in game when i connect it gets that weird screen for like 5 seconds (40frames) and then it switches to 125and then normaly everything is ok never fps drops in game only ETTV BIG DROPS dont now what this should mean but ok still got the weird bullet lagg cant get rid of it try’d so many things… wont help with the dual core optimizer looks it a littleee bit bether but it isnt the bullets still keep going to fucking slow :frowning: realy sad is there no way it can be the internet connection ?? what i dont realy think i surf so fast and everything have highest internet choose(turbo expressnet) so that normaly would be great but what could cause this realy big problem ? maybe just replacing some things indeed but its not that easy you cant just replace all your pc beacuse you have bullet lagg :slight_smile: you can but ok then you maybe need a lot of money pm me when you have a solution and sorry for my fucked up english imho:d:d:d

(grizzlybear) #84

does this effect show up easier with bullet tracers enabled ?

is it specific to one weapon (thompson, mp40, mauser)

is your cpu running anything else (idle process’s)

windows update trickling down the line ?

are you slightly too highly overclocked causing freaky little errors ?

(highbrid) #85

but you must now my 12V line is working @ 8.19 volt

if thats ur problem and a new power supply fix’s it ur one lucky kid.

on the plus side i played on snl sw last night and the demo’s i took are already motioned blured if i wanted to make a vid :wink: lmao.

does this effect show up easier with bullet tracers enabled ?

is it specific to one weapon (thompson, mp40, mauser)

this problem happens on every server, with a default or completely tweaked cfg, all weapons…or not weapons at all. if i pick a spot on the wall, strafe side to side, keep the crosshair on that fixed point…it’s choppy even with a steady 125 fps. at 43 u can tell it goes exactly with the problems in the lagometer.

windows update trickling down the line ?

never had windows update on but just in case i went and tweaked windows and killed any connection running in the background that isn’t needed to play et. computer starts and shuts down in half the time now lol.

and nope…not overclocked at all.

so far from reading thru posts with other poeple with the same problem they all have amd dual core cpu’s. anyone with this problem should post their system spec’s so maybe we can find a common piece of hardware that were all running.

asus a8n32-sli deluxe
bfg 7900gtx factory oc’d
amd dc 4400+
2g’s corsair pc3200
hyper typeR 580w psu
xp pro 2002 sp2

(grizzlybear) #87

@hybrid i have the same mobo ram psu with an 3200 and xfx6800gs
going dualcore soon

have you all tried without punkbuster (or run pbweb.exe in the pb folder)
crt or tft monitor ?
cl_maxpackets (same as maxfps) ? (edit thx mur)
rate 25000 ?

is this the problem (getting confused)

shoot>muzzleflash>delay>hit>smoke ??

(Irra) #89

Yes, grizzly, in my case that’s the problem. There’s too much delay between the shot being fired and actually hitting the target.

I have updated PB so it’s not that. Nothing in the background that would cause this / windows updates etc. Not a single in-game setting has effect on this. Even running with the lowest possible graphic settings it’s the same. Ping doesn’t effect this either.

so far from reading thru posts with other poeple with the same problem they all have amd dual core cpu’s. anyone with this problem should post their system spec’s so maybe we can find a common piece of hardware that were all running.

Not everyone has a dual-core cpu, but everyone who has mentioned about having this problem do have an AMD processor. Also, if I’m not mistaken atleast almost everyone from them do have a nForce chipset from nVidia… Could the chipset be causing it?

(murka) #90

maxpackets is cl_
“cl_maxpackets” 100(best)

(Nail) #91

update nforce drivers, couldn’t hurt, seems that fixed a similar prob before

(highbrid) #92

gelantine…about the same problem. turn your fps down to 43 with ur lagometer on and if there’s constant breaks that show up in the bar about 3 to 4 times a second then yes.

the first thing i noticed was the delay in my shooting and my aim droped from mid 40’s to 30’s.

next i noticed when i pick a fixed point on the wall with my crosshair and strafe side to side i get skips in fps even thou it’s steady. when i finally turned my fps to 43 i noticed the skips show up in the lagometer. (probably the cause of the shooting delay)

i’ve tried every fps/maxpackets…and even snaps settings i could think of and nothing fix’s it. i’ve reformatted and updated bios and video card drivers and still no fix. i use a crt but have tested with a lcd.

played on pb servers and non pb servers still the same problem. i know pb updated a while ago and added a process that run’s in ur system folders and is the cause of everyones getting kicked for loss of packet flow problem.

nforce drivers might be the only thing i havn’t tried updateing so thats what i’ll try next.

(murka) #93

hmm i have good fps and no lag but my acc is always 30-35% :x

(SCDS_reyalP) #94

Previous thread someone sent me on IRC http://www.splashdamage.com/forums/viewtopic.php?t=15187

I still can’t see any plausible explanation.

(grizzlybear) #95

when ever i had similar (not sure may have just been bad connection/fps) i just put it down to a bad server and reconnected to one of my favourites (shitstorm or btc )

maybe a bad server file is overriding defaults ?

common tweaks settings
enter /rate in console to see what rate you are using ect…

rate 25000
maxpackets 76 (cg_ cl_or com_ )
maxfps 76
hunkmegs 256 (?)(more mapsize/load related)

im sure theres another major one or two but i cant think of them at the moment.

(highbrid) #96

def not the problem. reinstalled et many times and tried many different cfgs on many different servers.

could the problem lie in our operating systems?

i have windows xp pro sp2. register’s with windows as authentic but is from a burnt disk and registerd to a school…but shhhhhhh.

(Nail) #98

Afaik, Microsoft’s way of dealing with fuzzy licenses is to deny updates, not disable your rig in any way. They also understand educational licenses have that “side effect” they’re still happy you’re using win and not linux.

anyone try updating nforce drivers ?

and btw, disable winupdate if you have it on auto, heard a few probs with it lately on XP

(Gel) #99

max_fps 43 does appear to have little gaps, but also some little yellow triangles that AREN’T there when I use maxfps 125

(highbrid) #100

anyone try updating nforce drivers ?

edit - and the nforce drivers and video drivers have been updated/rolled back/turned sideways/posted to council/waited for government official stamping/whatever else there is.

^^gelantine did lol.

i also get those little yellow spots where there’s skips but depending on the server they might be there as lil thin bars, triangles, or not there at all and i just get an empty gap. at 125 its not noticeable because of the ammount of frames that are being drawn in the same ammount of time. i’d say every 8 frames 1 or 2 goes missing on this computer…so more at higher fps but less noticeable.

anyone try any different hardware? mobo and psu are what i’ve had a chance to switch out.

(SCDS_reyalP) #101

http://wolfwiki.anime.net/index.php/Lagometer FWIW

(highbrid) #102

i’ve read thru that before but everytime it makes a lil more sense to me lol.

what i want to know is…am i consistantly not recieveing snapshots on a perfectly spread out basis, is my computer cutting these snapshots off…

or am i recieveing these snapshots and something is causeing my computer not to be able to draw the time between some of these snapshots which is showing in my framrate.


can video cards mess up in this way causing problems like this w/o showing it on the fps counter? who’s stealing my fps???

(AKA Sneaky) #103

I use

/cl_maxpackets 100
/com_maxfps 100
/cl_packetdup 1
/rate 50000

Also, instead of forcing 32 bit on graphics i just use default setting. My game runs fine on a full 64 players server in France (90-110 ping avg), and i’m in Quebec. I’m used to play in Toronto and New York (20-40 ping avg) but it seems all the good server i used to play with are gone or their half empty, i love playing etpro. :frowning:

I have:

C2d e6400
PNY 6800gs AGP
2gb OCZ pc2-5400

Also your computer might be infested with spyware and other kind of malware, trojan and everything that might affect your connection speed.

Anyhoo this works for me

(AKA Sneaky) #104

Maybe it’s your router. or firewall, network card, or anything between the internet and your network card (cables?).

(zig-zag) #105

One more thing to check, I haven’t read the whole thread, but if you have an nVidia card, there’s a setting for the driver “Threaded optimization”
Maybe turning that on/off might make a diff. Just a thought.