ET OSX 2.60d

(TTimo) #1

After working through the bugs reported on ET OSX 2.60c, here’s an update:

Replace your Wolfenstein ET executable by the new one, and drop the new qagame_mac into your etmain/ folder
You have a qagame_mac.bundle under etmain/ from the 2.60c installation, which you can remove


  • cursor problem when changing bindings in the control menu
  • now defaults to 24 Z-buffer, fixes Z-fighting problems
  • fix listen server crashing at the end of warmup and related crashes

Please give feedback, what is still broken, what’s fixed etc.
If all goes well I will make a more official release in a few days

(Duddits) #2


Fixed my crashing problem upon game start.


(bw) #3

Can we please have an id port to OS X that doesn’t litter its crap all over the place?

Props on using ~/Library/Application Data, but please have Punkbuster write somewhere other than the root directory and maybe name the Preferences plist properly.

(CompleteN3wb) #4

Anyone else having problems enabling PunkBuster?

pb_cl_enable doesn’t work and pb_ver returns nothing.

(jaybird) #5

Remove your previous PB installation in your profile’s Application Data. Then start the game and enable punkbuster. You’ll also probably want to update it before actually playing.

(TTimo) #6

the punkbuster installation package assumes you dragged the Wolfenstein ET folder to /Applications, and will - quite rigidly - put it’s stuff in /Applications/Wolfenstein ET/pb/

so if you installed ET somewhere else, copy that folder where it belongs

(bw) #7

I was actually talking about this:

% cat /pbcl.db 






Punkbuster doesn’t seem to work if the root directory isn’t writable.

(jaybird) #8

You’re not running ET as root by chance, are you? I have no files in my root directory and the game plays fine.

(jaybird) #9

Actually, I stand corrected (I spoke too soon!). I took a look at my file system and I do indeed have the pbcl.db file in my root directory.

(CompleteN3wb) #10

I was finally able to get this to work.

rm -rf /Applications/Wolfenstein\ ET/
rm -rf ~/Library/Application\ Support/Wolfenstein\ ET/
rm -rf ~/Library/Preferences/Wolfenstein\ ET\ Preferences
rm -rf /Library/Receipts/Install\ Punkbuster.pkg/
rm /pbcl.db

Then I ran the Disk and had it repair permissions. Didn’t see anything really strange there though.

Reinstalled 2.60c, installed Punkbuster from there, and immediately patched it to 2.60d without running it first.

Hope that helps someone.

(TTimo) #11

Officially released the update now. I’ve forwarded the PB thing to EvenBalance.

([PBSTAFF]Tony) #12


Thanks for reporting the bug regarding pbcl.db being written to the root directory. This has been fixed and future versions of the PunkBuster client will not exhibit this behavior.

Just for clarification, this bug only exhibits itself when PB is enabled from the Create Profile screen that pops up the first time you run ET. Unfortunately, PB is not completely initialized at that point but it “doesn’t know it”. Enabling PB via the pb_cl_enable console command or from another screen inside the game after your profile has been created should not cause PB to write to /. Once PB is initialized (both during the initial run and later runs), it knows to use …/Library/Application Support/…/pb (or whatever the fs_homepath cvar is set to) for storing its files.

The /pbcl.db file can be safely deleted. And PB does not require write access to the / directory in order to operate under OSX.


(woooopa) #13

Hi All,

For some time now when launching ET, my desktop cursor is frozen in the middle of the screen. The larger cursor appears and works fine. How do I resolve the issue of the frozen cursor?


(DG) #14

Patch ET-OSX-2.60c-to-2.60d.dmg
Full Wolfenstein ET.2.60d.dmg
mirrors via

(woooopa) #15

Thank you for your reply. I tried the patch as well as a reinstallation without success.

Any other thoughts?


(Nail) #16

remove divx codec

(woooopa) #17

how to please…

(k3nny_gat) #18

edit: after restarting i was able to delete the last bits and peaces of divx. now et runs quite smoothly.

(sascha) #19

Hi there,

I’m playing ET on an iMac Core Duo (first intel generation) with a Radeon Mobility x1600 Pro.

Enemy Territory crashes sometimes with no regularity, although I guess there is some coherence to etpro and etpub (classic servers are working).

Today I started ET in gdb and got some interesting output:

`/Users/sascha/Library/Caches/TemporaryItems/etmain/ui_mac.bundle/Contents/MacOS/ui_mac’ has changed; re-reading symbols.
2007-06-07 18:36:52.493 Wolfenstein ET[321] CFLog (21): dyld returns 2 when trying to load /Users/sascha/Library/Caches/TemporaryItems/etmain/ui_mac.bundle/Contents/MacOS/ui_mac

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000000
0x000e3e12 in ?? ()

Any clue how to solve this? Classic servers are rare, so I could use some help :slight_smile:

(pniel) #20

I have downloaded the new 2.60d version from the Splashdamage website twice already, but i have a problem.

As i try to mount the image, imagemounter reports that the image is corrupt and therefore cannot open it.

I find this strange.

I have a G4 powerbook with 13.9osx, which should be sufficient to run everything.

Can somebody help me?