Boktor's Project

(hozz) #101

[QUOTE=Boktor;437076]Funny thing, Hozz got the same error and made a post about it in the old tutorial thread. It sucks though, I can’t see if anyone answered him since the page 2 on the thread isn’t archived.
Step by step tutorial to making command map, heightmaps , deploymasks ect[/QUOTE]
I did never manage to get everything working, no secret solutions on the 2nd page :tongue:
The red/green squares + preview wireframe would not show before having placed the deployable, and the wireframe was hovering above the terrain after a deployable was placed. But I think they worked after arriving.

What made me give up was that I could never get the deployzone/territory switching to work, so there was no way to prevent people from placing deployables in enemy territory.

So I can’t help you. I don’t remember any mapping technicalities, that thread you linked only makes me go :confused::confused::confused: now.
Good luck anyway :smiley:

(Boktor) #102

Well I eventually got the playzone fixed for health packs and stuff. I just re-did it, got frustrated, tried again the next day and it worked. As Chris put it in IRC, it was one of those times the SDK “magically fixed itself”. So far I haven’t really wrestled with deployzone/territories since Techbuster is indoors. I guess things may have worked different for you since it was an older SDK version.

that thread you linked only makes me go :confused::confused::confused: now.

It’s funny you say this because your name is linked to a number of really useful tutorials. I feel like I should thank you :wink:

(Boktor) #103

Oi, we really should do a 2nd playtest.

How about today 8:00PM CET (2:00PM EST)??

The map is up on ICE Nexus Labs pass: redsnow

Spread the word :smiley:

(Boktor) #104

We had a great turn-out for the 2nd test today and played 3 rounds. We got up to an 8v8!

Dodging some rockets (but not all of them)

(d3v1ous1) #105

Great improvement Boktor.

(Boktor) #106

We played Techbuster in Nirvana today and I think we had some decent games

Howevers some strange issues came up that do not show up in the ICE Nexus Labs test server

  • Rainbow fog (but normal ambient lighting… looks kinda cool though)
  • Framerate issues (some ppl mentioned it but I need to know where)
  • People with connecting problems

As for the gameplay most people seem to agree that the Strogg attack is still too disadvantaged by the layout. For example, GDF spawn is too close to main area.

Please comment or post any suggestions you have and thanks to those that played today! Most people I’ve ever seen in Techbuster at once, 12v11!

(Donnovan) #107

TechBuster is avaliable to download?


(Apples) #108

First one is uber cool IMO :smiley: for some prefab industrial stuffs

I’m no mapper so no clue if these can be used or not… Hope that’ll help!


(Boktor) #109

Thanks that link will definitely help in my search. So many “free” model sites are really awful.

I went on one of the sites Apples posted. I tried importing into editworld, but I got an error.
It says: “Warning: ConvertLWOToModelSurfaces: model [thefilelocation/model.lwo] has too many verts for a poly! Make sure you triplet it down”
I guess I need to decimate it? I opened up some of the parts in Blender and the entire thing has to be more than 10000 verts. Does anyone know what a good amount of verts is for an in-game model?

Even if I do find a model I will probably still have to do texturing(?), and I have no experience in that sort of thing. I just did some quick brush and patch work and made this test. Strogg for reference :oppressor:

I think it’s decent. If it’s going to be in-game it could use more detail, but it’s not something players will really interact with. That bright light is a flare texture. The texture only seems to like being stretched to 4-sided shapes. Is there any way to get it to a nice circular shape? I’ll even settle for a hexagon.

Anyway for this week and the next I am in study-mode for finals, so I won’t be doing much for now! Scrupus if you see me on Tribes make sure I get off :smiley:

(Scrupus) #110

hehe command accepted - if I see you online in Tribes I’ll do my best to make you rage quit :wink:

The brushwork lamp looks good enough, go for that for now. 10000 polys is a lot for a model I think, not sure how much is normal for a low-poly but maybe you find some better ones later on. You could decimate it but it’s probably not worth the effort. I’m pretty sure there is a set of lamps for W:ET (or maybe RTCW) posted somewhere, at least I got some in my etmain dev folder from long ago.

Well good luck further on, and hope we see a first-playable this year - added to the Santa Makron wishlist! :oppressor: :tounge:

(Boktor) #111

I just finished my last final this morning. The project is now re-activated :cool:

(Boktor) #112

I just noticed something weird with one of the textures on the walls. As you can see it’s only in-game when I test it out with devmap…
EDIT: I just fixed it so I’m taking down the image. It’s here if you want to see it. I have no idea why it happened, but flipping the texture face horizontally seems to fix it.

Anyway, here’s what the light-fixtures look like in game

(Scrupus) #113

Light-fixtures (and lightning) looks great, room details as well! :slight_smile:

The texture problem happens sometimes, but as you’'ve learned it’s just to modify the texture properties a bit.

(Boktor) #114

Sorry guys I had a long holiday.

When I’m placing a model I don’t want to see it’s shadow. However, the light affects some brushes. I want to see the brushes’ shadows. Is there a key I can change to turn off the shadow-casting properties of a model?

(Boktor) #115

Oh and Chris are you still up for this?

(Scrupus) #116

Put it in a lod group:

noShadows - Enable to turn off shadows in this group.

I recommend to put each model in a reference and use the lod groups there, especially for repeating models. Makes it more handy to tweak those LOD settings later :slight_smile:

(Boktor) #117

Do I have to use 3 subgroups for LODs all the time. Wouldn’t just 1 group work in this case? I don’t want the shadows to show at all.

edit: nevermind. ha it’s right in front of my face. I see the numstages tab. I haven’t used LOD groups for anything yet. Everything is in editor groups.

(Scrupus) #118


“New LOD Groups have 3 levels by default. Change this to 1 by selecting ‘New Group’ and change its Num Stages property to 1.”


Edit: Some of the other properties mentioned there can also be quite useful for models, for example Inline Collision Model and Instancing.

(Boktor) #119

Heh I edited my post just before you. I found it :wink:

So now I have put the model in a lod group with 1 level. I set noShadows to true and it still shows shadows. I recompiled and I still see it in the sdk 3d camera

(Scrupus) #120

hehe :slight_smile:

But that was a bit strange - check it in-game as well, maybe the sdk camera doesn’t honor all of those properties.