RtCW with support subtitles


(Eugeny) #1

I present to you heed modification RtCW supports subtitles.

//youtu.be/Swvebpq2cEM

Modification adds support for subtitles
Only Windows
The archive also contains an example subtitle file for map cutscene1

Download here RtCW with support subtitles


(ronboy) #2

Nice work, Eugeny! :cool:


(tzs) #3

cool work!


(kost3k) #4

And how to add subtitles e.g. in Village mission when Kesler says: “Hey, don’t shoot, I’m Kessler!” ? Few years ago my friend had a rtcw with polish subtitles but i don’t remember from where he had that version :expressionless: But I’m sure that I played rtcw with subtitles those few years ago :stuck_out_tongue:

Edit: And subtitles was also in game’s intro.


(ronboy) #5

[QUOTE=kost3k;407330]And how to add subtitles e.g. in Village mission when Kesler says: “Hey, don’t shoot, I’m Kessler!” ? Few years ago my friend had a rtcw with polish subtitles but i don’t remember from where he had that version :expressionless: But I’m sure that I played rtcw with subtitles those few years ago :stuck_out_tongue:

Edit: And subtitles was also in game’s intro.[/QUOTE]

It seems the English version didn’t officially get subtitles.


(kost3k) #6

So I’ll ask again. Your modification allows to add subtitles only in cutscenes, or also in dialogues (e.g. in Village mission when Kesler says: “Hey, don’t shoot, I’m Kessler!”) ?


(Eugeny) #7

oops, I think that answered the question.

here http://wolfmap.ru/forum/viewtopic.php?p=29467#p29467 (rus)


(kost3k) #8

I’m not so good in other languages as in mine (polish), so it was hard to understand, even with google translator, but after about 40 minutes I finally understand how does it work… :smiley: I’m very proud of myself now :smiley: In some free time I’m going to work on it :slight_smile:


(Eugeny) #9

Archive is updated, the changes:

  1. Removed a bug with shooting under water from Tesla;
  2. Removed a bug with shooting from the flamethrower in a mode noclip.

(kost3k) #10

Sometimes the subtitles disappear too fast. Is there any way to increase the time in which they are displayed?


(Eugeny) #11

Archive is updated, the changes:

  1. Added ability to disable\enable subtitles.
  2. Slightly increased time displaying subtitles

(ronboy) #12

Thanks Eugeny! Downloading now.


(Eugeny) #13

Archive is updated, the changes:

  1. Fixed some defects;
  2. Changed version of the file of saved games to 19.

(Eugeny) #14

//youtu.be/Swvebpq2cEM


(kost3k) #15

Excellent work!! Thank you! :slight_smile:
It’s going to be an unofficial SP patch :stuck_out_tongue:


(Eugeny) #16

Archive updated!
Fixed small bugs!


(Eugeny) #17

Returned the help screen is displayed with the command “help” from the console


(kost3k) #18

Can you add the widescreen resolutions support? I have 19’ monitor with resolution 1440x900, and my game crashes on cutscenes when I’m using r_mode -1. :frowning:


(Eugeny) #19

use:
r_mode -1
r_customwidth 1440
r_customheight 900


(kost3k) #20

I’m using this settings already. And my game always crushes. I must switch to e.g. 1024x768, then watch or skip cutscene, and then return to my native resolution. It’s so annoying…