R_usethreadedrenderer 2 does cause stuttering with Linux

(you_is_me) #1

since my new setup I can´t set r_usethreadedrenderer to 2 without problems. It makes the world (e.g. trees) glitchy and is actually unplayable. r_usethreadedrenderer 1 and r_usethreadedrenderer 0 works fine.
Using Wine it does work fine.

I´ve made a small video. In real it is way more noticable… but it should be visible on the video too.

It would be interesting to see if it also happens on Quake 4 or other idtech4 Game.
I think it may has to do with Zen2 (3700X). Solarisk got (nearly) the same GPU as me and he said it works without problems for him.

Any idea? Where should I open a bug report? Or does someone even have a good fix?

(REA987) #2

r_useThreadedRenderer has always been a bit interesting variable. To my best knowledge, it was added to the game with v1.2 which means the game either wasn’t designed for it or SD simply couldn’t managed to ship the game with it at launch. In any case, Quake 4 too received similar setting named quake4-smp later on. Interestingly enough, Prey (2006) has no such option. Back in the day, @Pliscin-7 / @Pliscin-71 released a config video that didn’t have r_useThreadedRenderer at 2, yet managed to get 3 if not 4 digit framerates. So, it is not a necessity but surely helps. If you don’t have one, I can lend you my Quake 4 key, so you can test the native game. Or you can simply purchase it on ongoing Steam Winter Sale 2019, the game is shipped with a CD Key that can be used with Linux native version. Finally, why don’t you consult @ressected / @dissected ?

( None) #3

Are you sure thats the problem? It may, be caused by something differente even by a net_ setting … we have proved with numb a net code that caused him lagg and buggy, maybe it’s the same with you

(Solarisk) #4

I tried recreate your game behavior, by restoring settings to default state. And there is stuttering with ‘r_useThreadedRenderer 2’. When I change corresponding variable ‘com_unlock_timingMethod’ to ‘0’ problem is gone (you probably have default ‘2’). There is old tweaks guide which describe unlocking FPS and multi-core: https://web.archive.org/web/20191028155006/https://www.tweakguides.com/ETQW_9.html

(REA987) #5

@you_is_me have you tried that?

(you_is_me) #6

I am sure it is not a net setting because I even tried it without a cfg.
com_unlock_timingMethod is 0 of course.

I’ll get further into this when I get my new GPU…

(it randomly stopped working an I am waiting for repairs. This is the reason why I “left”)

(you_is_me) #7

So, I am finally back :slight_smile:
After upgrading my Distro I still got this issue sadly.
Works fine using Wine.

Yes, I use
com_unlock_timingMethod 0
r_useThreadedRenderer 2

If I enable VSYNC (max out @ 240 FPS) it´s fine too.

No idea what is going on.
It may could be I am using amdgpu driver while others may use amdgpu pro?

Edit: I made this note in my startup script:
“vblank_mode needs to be 1 and also r_swapinterval needs be 1 if we want use r_usethreadedrenderer 2 otherwise we got jitter”
(vblank_mode being an env. var. while r_swapinterval an ETQW setting)

So my options using linux are:
r_useThreadedRenderer 0 / 1 and unlocked FPS
r_useThreadedRenderer 2 and synced to Monitor