Q3Map2 2.5.16

(ydnar) #1

Q3Map 2.5.16

Some stuff for Sock mainly. Since the last major update was in July, one can assume that my involvement with Q3Map2 is in decline. Well, that would be valid. Since July I’ve started a new job, been dating a wonderful woman, and spending far too much time reading about history, politics and bicycles.

Incidentally, it was a complete and total accident the new bike I’m picking up tomorrow has the exact same paint job that John Kerry’s does.

Download: Win32 - Linux x86


Version history/changes:

2.5.16 (2004-10-18)

- New: -fixaas mode to reassociate an AAS file with a changed BSP
- New: -nostyles switch on light phase disabling lightstyles
- Using libmhash cryptographic hashing library instead of md5lib


(nUllSkillZ) #2

Great news ydnar.
:banana: :clap:

(TheJediYoda) #3



(Shaderman) #4

Thanks ydnar for this new version and the time you spent with sock to give us a new plaything :smiley: and best wishes for your relationship :wink:

(Hybridesque) #5

Hehe, it now gives me a chance to catch up with all the additions you’ve made to Q3Map2 over the the last couple of months if not the last 2 and bit years!.. if it weren’t for my final year at University, which is getting rather stressful.

(obsidian) #6

Congrats on your new job, new love and new bike (post a picture?).

Are you still working for a game development company or are you doing something else now?

(Grand Nagus) #7

Awesome! Thanks for another great map compiler, ydnar.

  • New: -fixaas mode to reassociate an AAS file with a changed BSP

That sounds like a really cool feature, but I can’t get it to work… I’m using batchfiles for my map compiles, so how would I word a batchfile that would run that ‘-fixaas’ switch? All I can do with it is render my .aas files inoperable. Can you tell me the correct command-line syntax for q3map2.exe to get ‘-fixaas’ to work? Here’s what I tried, and it doesn’t work (this is for Elite Force):

“E:\Applications\Games\Raven\STVEF\Tools\NewCompiler\q3map_2516\q3map2.exe” -fs_basepath “E:\Applications\Games\Raven\STVEF” -game ef -fixaas %1

I created a simple map, and then created an .aas file for it. I tested it in Elite Force, and bots played on the map just fine. But after I dragged that map’s .aas, .map, or .bsp file to this batchfile, the text at the command prompt said that it tried three different .aas files and then got done in one second. The timestamp changed on the .aas file, and when I tried to load bots on that map I get an aas error (the same error you’d get if there’s no .aas file created for that map)… It’s as if the ‘fixaas’ switch broke the .aas file! How do I get it to work? I gots some ideas I wants to try, but I can’t get this option to work.

Thanks in advance for the help! :slight_smile:

BTW, I heard that somebody stole John Kerry’s bike… :smiley:

(Whistle Master) #8

Hello !

And what about Q3Map2 2.5.16 for Darwin/OS X, do you plan to release the new version for OSX ?


Sorry for my english, I’m a poor little frenhy :chef:

(cgbeige) #9

here’s another request for the OS X version or a little help to compile it for future versions too. i have a map that desperately requires the alpha volume fading features.


(TF) #10

hmm,cant download , link isnt working :poke:

(nUllSkillZ) #11


(Twisted0n3) #12

Shaderlab is still not back up? It’s been two weeks now. That’s ludicrously long downtime.

(hadro) #13

Hi all
q3map_2.5.16_win32_x86.zip has a good mirror now thnx to obsidian.
Can anyone help me get q3map_2.5.16_linux_x86.tar.gz ?
simply cos linux rules and my winxp system is sLoW

thank you

(flower.Hercules) #14

Same boat as you. Except I don’t use Windows because I have no use for it, there is nothing for it that I need except … Q3Map 2.5.16 :slight_smile:

I posted a thread just last night about this, a little below here.

(kamikazee) #15

Are you sure you really need the latest version?
I do most compiles with the version supplied with GTKRadiant, and it does the trick.

(flower.Hercules) #16

I need the alpha stuff, and GTKRadiant 1.5 is buggy with my compile of GTK, so I have to use 1.4.0 :frowning:

(flower.Hercules) #17

To all interested:

Get the latest version of GTKRadiant (1.5.0) and conver the RPM to a tar.gz and unzip it and just use that version of q3map2, it is the latest 2.5.16! Huray!

(joop sloop) #18

I’ve made (another) mirror of the latest q3map2 version: http://q3map2.everyonelookbusy.net/
I’m still looking for the *nix and os/x versions. If someone can send me those I can add them to the mirror…

(Higgins) #19

Has Shaderlab completely died now?

(Superdreadnought) #20

where can i download the linux version?