[HUDEdit 2.0.1] The Software to Modify Your HUD! - NOW WITH UHD SUPPORT!


(Xyfurion) #1


HUDEdit by Xyfurion
Infuriate Your Future, Today!

The day has come upon us. Finally, after much anticipation and delay, HUDEdit is ready to be released!

HUDEdit is a third-party application that features a way to change most aspects of your ingame HUD to your liking!

NOTE: Somethings will not appear as shown in HUDEdit. This is due to a bug from SplashDamage (confirmed by Shoe.). You can see which assets are affected most by this in “Known Bugs.”

Download Links

Latest - HUDEdit 2.0.1

HUDEdit 2.0.0

Changelog

2.0.1

  • Added UHD Support

2.0.0

  • Added Log Files
  • Added all the images
  • Improved functionality
  • Added shifting via arrow keys
  • Fixed bugs
  • Removed unnecessary images

ToDo List

  • Implement “Load Preset” and other Preset related functions.
  • Make window size independent of resolution.
  • Fix Bugs.
  • Make Dragging function smoother.

How To Use

  1. Make sure you have Java JRE downloaded and installed from here.

Remember, the version of Java you have downloaded does not necessarily match your OS. You could have 32-Bit JAva on a 64-Bit system. If one version does not work, try the other one.

  1. Navigate to the files you downloaded.

http://i.imgur.com/rsIgQA0.png http://i.imgur.com/EzHAoiO.png

  1. You will now need to extract the ZIP File contents.

  1. Navigate to where you extracted HUDEdit and double click (or right click > Run as admin).

  1. Select your Resolution Ratio and Resolution

  1. Enter fullscreen mode.

  1. Now you can click and drag stuff to your liking.

  2. You may want to open up the Options window, you can do so by clicking the cog at the bottom left or by right clicking anywhere on the screen.

  1. Here you can play with stuff until you like what you see.

http://i.imgur.com/zJjroX5.png http://i.imgur.com/hP3mxVx.png

  1. Once you are done, click “Save Preset” in the Options Window and save it to a place you will remember.

  2. Navigate to the following location: “C:\Users\YourUserNameHere\Documents\My Games\UnrealEngine3\ShooterGame\Config”

  3. Create a Backup of the ShooterUI.ini file.

  4. Drag and drop your newly created (by HUDEdit) ShooterUI.ini file into this directory.

  5. Start the game!

Controls

  • Right Click: Opens up Option Window.
  • Left Click: Select an object.
  • Left Click + Drag: Move stuff around.
  • Arrow Keys: Move stuff around by 1 pixel.
  • Ctrl + Arrow Keys: Move stuff around by grid size.

Videos

Known Bugs
Report unknown bugs here.

  • “Show only selected” does not work properly. Only works if object is currently selected.
  • “Reset” and “Reset all” functions cause the app to crash.
  • “Revert Settings” function DOES work, but will not re-open the app as intended.
  • Scrolling through the HUD Assets will cause a visual glitch and cause assets to go off-screen.
  • After updating, “Launch App” does not always launch the app.
  • Stuff snaps to another location after selecting.

Somethings are misplaced compared to what is seen in HUDEdit. This is due to a game bug on SD’s side. Not everything is affected though. Most notable ones: GameWaveTimer (significantly), MiniMap (slightly), DetectedNotification (slightly), and XP Counter (slightly).
It’s not my fault

FAQ
Read before posting.
Q. Why did this take so long to release?
A. I sincerely apologise for all the delay and disappointment, but hear me out. The main reason for the delay was simple. I had little incentive to keep working on HUDEdit as I had stopped enjoying it. The second reason (which isn’t that big a deal) is that SD would keep changing the ShooterUI file every few updates, which threw me off and caused me to stop work on it for a few weeks. Third reason: school.

Q. Will I get banned for this?
A. No. You won’t get banned for changing your HUD.

Q. Is this a virus?
A. No. Scan it yourself.

Q. How old are you?
A. dy/dx y=4x^4-4x^3+6x^2 at x=1. Solve it.

Q. Did you make this yourself?
A. Yes.

Q. HUDEdit is not opening. What do I do?
A. Ensure you have the latest version of Java JRE and that it matches the version of the app you downloaded (ie. If your Java version is 32-Bit, use HUDEdit 32-Bit. If your Java version is 64-Bit, use HUDEdit 64-Bit).

Q. I keep getting “JNI Error.” What do I do?
A. See above.

Q. HUDEdit shows me the “Select Resolution” Window but then nothing else. What happened?
A. Download the ZIP archive and ensure it matches your Java version (Not necessarily your OS version).

Q. Images keep “jumping” to another position when selected. Is that supposed to happen?
A. Yes, they are simply snapping back to their correct position. the misplacement is due to an unresolved bug.

Q. There are some buttons in the options window that I cannot click on. Why not?
A. Those features have not been implemented yet due to complexity or lack of importance.

Q. There is something not working. How do I fix it?
A. Use the bug report form to report your bug (with the log files) so I can get around to fixing it. Please check the “Known Bugs” section before submitting a report.

Q. Why does HUDEdit not let me click anything else?
A. This is a necessary measure that allows HUDEdit to go into fullscreen mode with ease.

Q. I minimized HUDEdit. Where did it go?
A. There should be a grey bar (by default) at the bottom left of your screen. That is where it minimizes. Another necessary measure.

Q. Some assets are misplaced. Wtf dude?
A. Yes I am aware. This is due to a bug from SplashDamage (confirmed by Shoe.). You can see which assets are affected most by this in “Known Bugs.”

Q. I made a HUD and put it in the config folder but I still get the default. How can I fix this?
A. There is a workaround you can use. Set the custom generated ShooterUI.ini file to read-only (Right click > Properties > Check “Read Only” Checkbox).

Special Mentions and Appreciation

Special Thanks to:
[Sudo]µHD
Kirays
[SD] shoe.
[OCB]Andarne
bontsa
amerika*
3N1GM4
Simple_AOB
PhynX
Xenithos
[/spoiler]

By downloading and using HUDEdit, you are agreeing to these terms of use


(Kirays) #2

Hell, yeah! It’s finally out.

Thanks for all your work, I’m sure everyone appreciates it.
Have a cookie. :cookie:


(Flong) #3

man i fucking love you, also do we download zip and setup?


(Flong) #4

been waiting for this for so long


(Xyfurion) #5

Either one. Doesn’t matter.


(Nail) #6

@Stoker there is a “How to Use” spoiler, you might try reading that


(Xyfurion) #7

Never thought I would have to say this but if anyone thinks @stayfreshshoe playing Turtle is real, sorry to disappoint, it is not. I used Turtle because I wanted to… Apparently some people took it seriously. :disappointed:


(Madonna_) #8

Thanks! Great work


(tenderGecko) #9

thanks for your work mate, I seem to have run in to an issue I can’t resolve.

it opens just fine, I select resolution and hit ok.
then nothing happens and the entire program just disappears, any idea what could be causing this?


(bontsa) #10

This is absolutely fantastic job you’ve decided to plow through here mate, well done! Thank you very much for this.


(x3mytiz) #11

Same problem here, but I am on work PC. I will try again tomorrow, at home, on my gaming PC and come with feedback.
Anyway, thanks @Xyfurion for your work, when I’ll see you on battlefields I will give you free health/ammo packs, even you will be in red team!


(tenderGecko) #12

Same problem here, but I am on work PC. I will try again tomorrow, at home, on my gaming PC and come with feedback.
Anyway, thanks @Xyfurion for your work, when I’ll see you on battlefields I will give you free health/ammo packs, even you will be in red team! [/quote]

tried both 32 and 64 bit seperate, no succes.
either i am lacking additional software or something else on my pc is hindering the app from working properly.

sadly i am not very well versed in dealing with such problems :frowning:

for what it’s worth i’m running Windows 7 64bit (6.1, build 7601)


(K1X455) #13

I give you cookie


(BlackboltLW) #14

This needs to be sticky’d


(GatoCommodore) #15

Sasuga @Xyfurion sempai

here have 9 virtual insightful since i cant give 10 in your post

dunno why i cant open the software tho
i downloaded both and opened both in admin


(wickedPalanquin) #16

I have downloaded this but i wont open and i get no message come up plz help


(Speedless_Flash) #17

after setting ratio & resolution nothing happens. Checked taskmanager and jawaw.exe pops up and dissapears again.

Dying for a FIX!!!


(DaaDog) #18

I can’t open either of the files listed here.


(doxjq) #19

Yeah mine doesn’t open either. Win7 64bit here. Double click file, loads for 1-2 seconds then just nothing.


(KoelKastVarken) #20

Yea i have the same problem as most of us, cant open it on the 64-bit version, and the 32-bit has the problem that it ask your resolution and then nothing happens after you click ok. :frowning:
(I am running Win10 64-bit)