GUID/etkey Generator

(BigBear) #1


As an old School Coder…


Be Fair & Have Fun !


(zbzero) #2

i exec it and it do nothing

(BigBear) #3


I use Windows XP :wink:

And you ? it come perhaps of that…
** Please, Try to set compatibility mode to the oldest Windows version **
Firewall ? Antivirus ?

Perhaps that you cannot see the text but it should write the file (to test delete your GUID/etkey) and :
==> Click the opened windows try to press a key 2 time if you see nothing it can work too… :slight_smile:

Please thank you to provide me a Feedback of what is working :wink:

(zbzero) #4

i tested in win xp and 7 and not works, i extract the zip in a folder (not default et folder) and exec it, no etkeys at all.
Need to do something different?? can you please say if need to be at et default directory or not?

(BigBear) #5

Oops I have tested it on some many SPx versions :slight_smile:

No need to extract you can exec directly.
You can exec it from any place it should put the file in game folder automatically
I try to make it working almost as possible :slight_smile:

But please download it again I have used another Compiler :slight_smile:

(Same link but new compiled version)

(zbzero) #6

for me it still not working!
Maybe you coud modifie this program to save the etkey in the same folder of etkeygen.exe file!

(BigBear) #7

Thank you :wink:

On mine it works :wink:

If it do not Work on XP it seem to be those kinds of problems created by antivirus of firewall that could possibly lock access to your hdd.

  • I suggest to all to prevent use of full life time FREE antivirus because they s*ck… * Including WET kicks while playing
    If you do not trust me read TZAC advice regarding that point…

Here I have done a local version that I have included in :wink:

(Same link but include the Both versions)

p.s : GenSameFolder need to be extracted

If it do not work please try what I have said up… because sure on XP any versions it work.

For the newest Windows you need to add etkey file here :


You can use this nice utility to help you to find your etmain Folder, just type etmain in :

Thank you :slight_smile:

(zbzero) #8

if i use GenSameFolder it works but the other didnt! Thx!!

(BigBear) #9


Thank your for your support for having help me to solved that… :wink:

Now users have the choice with the both versions in the .zip :wink:

(2n2u) #10

I used it under Linux and generated the etkey, I put it on my etmain folder but keep getting the error “empty cdkey” by punkbuster :s

EDIT: Nevermind, managed to get thinks working :slight_smile:

(Problem) #11

Dude, I registered only to say this: YOU ARE OVERPOWERED! :wink: I had the problem that had no etkey at all. Your generator fixed it! THANKS MATE!

Edit: Generator worked for the first time. It created some code that I saw when commanded /pb_myguid
But when I tried to join a server came “Game code failed pure server check”.
Then I put game launch as administrator and GUID goes no_guid…

Please help me! :slight_smile:
Greetings, Problem