fps and hz

(Valdez) #1

For whatever reason when playing dirty bomb it feels like I am running 75-85hz, I average around 180 fps, but feels like I am running 60fps. When I turn on vsync it feels very smooth at 120hz and i have a steady 120fps, but the problem is I have very noticeable mouse lag/input lag. Is anyone else having this issue?? My system specs are in my signature.

(Humate) #2


Have you tried this with vsync off Valdez?

(tokamak) #3

Yeah somehow 30fps in DB feels much slower than 30fs in ETQW.

And yeah I can’t put my finger on it really but last night I did feel like there was a latency in what I did with my M+KB and what happened on the screen. I can’t prove this but it definitely feels different from other shooters. And that’s with reasonable fps and a very good ping.

Vsync automatically limits the fps to 30fps so I guess he tried that. I think that in this day and age it would be better to have vsync off as a default so people can just start with high fps straight off the bat, which is good for a first impression.

(Valdez) #4


Have you tried this with vsync off Valdez?[/QUOTE]

I have tried that, however when editing the config files dirty bomb makes me redownload the game. Anyone had any success editing the cfg outside the game???

(ailmanki) #5

I just tested it again, I modifed the existing ini entries, started the game, it didnt redownload it, and a manual verification of game data worked also.
modify the file in following folder:
c:…\WarChest\Dirty Bomb\Published\Content\ShooterGame\Config\ShooterEngine.ini
The file is existing more then once in the folder structure, maybe;{but it is the file which holds your personal configuration}.

Basically it seems the idea is to force the game to generate enough fps for vsync (I am still new UE3, my fingers are crossed), so that mouse movement is not lagged in the end. (http://forums.epicgames.com/threads/740087-How-to-play-UT3-with-vsync-on-and-no-input-lag)
So it should be possible to change it ingame… didnt work for me though, but didnt have the patience to experiment.

For a 60hz screen, that should be a minimum of 59 and max of 60.

(Valdez) #6

thank you ailmanki, apparently i was trying to change the cfg in a different folder.

(Humate) #7

Sorry valdez, should have pointed out which directory.

(Valdez) #8

Why is it that with bSmoothFrameRate=True or even with it at False, when uncapping the fps the game feels terrible?? The game feels by far the best with vsync enabled but this introduces very noticeable mouse/input lag. Next best option would be bSmoothFrameRate=True, MinSmoothedFrameRate=120,
MaxSmoothedFrameRate=120. With those settings you get what feels like frame drops (feels like it goes from 120 to 30fps), even though with uncapped fps i never go below 150 fps, also still get major screen tearing with those settings. Basically no matter what settings or what hardware you have the game is just not smooth, I understand its alpha but am just hoping that this game will run way better.

(ailmanki) #9

@Valdez Try what this guy said in the second link I posted …

The solution is to have vsync turned on and have framerates limited below your refresh rate. So if you have an LCD and refresh at 60hz then limit your framerate to 59. If you run 75hz then limit to 74. As long as framerate smoothing is limiting your framerate instead of vsync there doensn’t appear to be any noticeable input lag.

I am moving, will take another month or two before I can go back to my PC and test all this stuff out. I was only able to play once or twice with these settings before I had to pack my PC. And I had just vsync off and min/max to 120. It seemed more stable, but still some lag. But I thought its related to my crossfire 2x HD 5750. Have to get a gt 680… :slight_smile:

(Valdez) #10

Ive tried everything ailmanki, I have a 120hz monitor and tried putting it at 119 limit. Problem is my computer has an issue with locking fps to my monitors refresh rate, every game i do that in I get horizontal visual tearing across the screen that is one inch in height. Really the only solution for me is uncapping the frames, however in this game it still runs terrible. I installed blacklight retribution last night since it uses the same engine, wanted to see if it had the same issue. The default setting for that game are bSmoothFrameRate=True and uncapped fps, and it runs 100% smooth with 0 issues. Hopefully at some point this game will run smooth with uncapped fps. SD is this something you guys are working on hopefully?? I know its alpha.

(ailmanki) #11

In any case, if you can - don’t use vsync, it gives a slight input delay afaik. For fps I think it should be screen refresh rate +1 or +2. If its similar to Q3, in terms of it has to be a divider of 1000, then you should use 125fps for 120hz. This laptop I got is to slow, can’t reach 30fps… hehe.

Be also sure to create a extra profile for DirtyBomb in nvidia control panel. And experiment with forcing vsync settings from there. Might give different results - then ingame vsync.

(Valdez) #12

at first it really did not make sense what you were saying ailmanki, I thought if you had vsync on it would auto cap at your monitors refresh (120). You are right though, with vsync enabled in the drivers/119 in cfg it does lock to 119 and has vsync on. I used this combo with triple buffering and it seems pretty good, these will be the settings I run with till they fix the uncapped fps issue. Thank you.

(Valdez) #13

Just wanted to bump this thread. No matter what commands i have tried the game still feels like 75hz with about 60fps(unless vsync is on which gives mouse lag), the mouse feels very floaty even with vsync off. I probably average 160fps and im on a 120hz monitor(soon to be 144hz)Is this something that can be fixed SD? or hopefully it is something you guys are working on. Also does anyone else have similar issues?

(LeeStyle) #14

I agree, the “feel” of the game is far from smooth, it’s a very rough feel that is only lessened by turning on vsync and bringing in tons of input delay.

(INF3RN0) #15

Extreme screen tearing and overall lack of visual smoothness. After some further investigation I think this issue is related to screen aspect ratio. When I set my native 16:10 to 4:3 the game looks significantly smoother, however I get those pesky black bars. I’d recommend some of the tech department take a look into this.

(iwound) #16

i set my 16:9 to 4:3 and its fine no bars. you tried 5:4 might be better.

(LeeStyle) #17

You can always use stretch to fill feature available on any monitor or video card to stretch the image to fill the screen when at a non native aspect ratio.

(EnderWiggin.DA.) #18

With 15404 I noticed the max frames is 90 whereas it was 120 with previous patches. Vsync is on. Monitor is 120 hz. How can I change it back?

/Haven’t tried the new patch yet.

(Kinjal) #19

Same 90 FPS

(Breo) #20

for me it’s also capped @ 90 fps