Can somebody tell the world how to INCREASE bots on maximum ????

(Svetlozar) #1

I got the game its awesome but with 8 bots … COME OOOOON so please help me and other guys like me to increase the bots on maximum … PLEASE

(Dthy) #2

if your playing offline, start a match then go to the limbo menu. Under the tab called “Server” (i think) you can change the amount of bots to a 16 v 16, difficulty, etc.

(Svetlozar) #3

naaah nothing happens if I try to change the Strogg or GDF to 16 when trying strogg the GDF drops JUST like in the main menu when Im playin Object etc :frowning:

(Svetlozar) #4

I just FOUND that: Please how do u get more bots 8 a side is small and no good for spawn camping and a real big fight and the maps feel bear
i found this but i cant find gui file and console is disabled

ctrl+alt+~(tilde) to open console
com_allowConsole “1” to open with the traditional ~(tilde)

then those cmd and ur done, as said, the limitation is only in the GUI(the menu where you select bots when you press “play computer”).
enter the commands he said in the console and wollah, 32 player serv filled with bots and you

(Svetlozar) #5

i CANT OPEN THE PAGE ?!?!?!? if some one can please tell me what I have to do

(hozz) #6

It’s a little complicated, but this is how to do it:

  1. go into game and choose your team
  2. open console by pressing ctrl+alt+^ (left of “1” button)
  3. enter these 2 commands (confirm each by pressing enter):

bot_minclients -1
si_maxplayers 32 

You only have to do that one time, not everytime (hopefully).
4. now you can the add individual bots with the commands

admin addbot gdf
admin addbot strogg

  1. Play:)

I hope this works.

Also: if you dont want to do that every time, do the following:

  1. Rename the attached morebots.txt to morebots.cfg and put it into your program files/id software/etqw/base folder.

And then:

  1. go into game and choose your team
  2. open console by pressing ctrl+alt+^ (left of “1” button)
  3. type

exec morebots

and press enter
It will add as many bots as possible (32 player maximum)
4. play

(Svetlozar) #7

thanks every body I will try that now

(Svetlozar) #8

well done dude WELL DONE :wink:

(brbrbr) #9

si_maxplayers had no effect above “32” w/o binaries editing ?

(hozz) #10

32 player max is apparently hardcoded, so yes.

(murka) #11

32 clients is hardcoded in the engine. You could try and rewrite the bots without them being clients to increase max, but that’d be like beating a dead horse.

(light_sh4v0r) #12

I don’t think your PC would manage hosting a game with more than 32 bots anyway.

(Donnovan) #13

Players are always focused in one objective, 32 or more playing one objective is too much. May be if it have multiple fronts to to attack, like in a real war (plastic peons on a map).

(brbrbr) #14

played OFP:R CTI with 256 players from 2003.
also “played” UT99 with thousands of bots[thanks to “addbots” built-in alias], being killed in about 1.2 seconds after respawn :stuck_out_tongue:

(Svetlozar) #15

hozz has the solution everybody do what he said in his comment IT WORKS !!! now with 32 players the game is from AWESOME to INSANE meaning FREAKING AWESOME :smiley:

(Svetlozar) #16

thanks everybody with the help really apriciated :wink:

(zabas) #17

I launch the server with 30 bots enabled but they only play one campaing.
On second one there are no bots even using “exec bots.cfg” in my server.cfg file.
If I use 16 bots the play all the campaings.

(taw_m0nsta) #18

i guess playing with 25 bots will make the game think you no longer run anything vanilla. You can setup a custom campaign rotation in the server.cfg

something like

set m1 “set g_nextMap $m2; spawnServer campaign_africa”
set m2 “set g_nextMap $m3; spawnServer campaign_northamerica”
set m3 “set g_nextMap $m4; spawnServer campaign_northeurope”
set m4 “set g_nextMap $m1; spawnServer campaign_pacific”

(taw_m0nsta) #19

or create 1 big campaign

set m1 “set g_nextMap $m2; spawnServer area22”
set m2 “set g_nextMap $m3; spawnServer ark”
set m3 “set g_nextMap $m4; spawnServer canyon”
set m4 “set g_nextMap $m5; spawnServer island”
set m5 “set g_nextMap $m6; spawnServer outskirts”
set m6 “set g_nextMap $m7; spawnServer quarry”
set m7 “set g_nextMap $m8; spawnServer refinery”
set m8 “set g_nextMap $m9; spawnServer salvage”
set m9 “set g_nextMap $m10; spawnServer sewer”
set m10 “set g_nextMap $m11; spawnServer slipgate”
set m11 “set g_nextMap $m12; spawnServer valley”
set m12 “set g_nextMap $m1; spawnServer volcano”
vstr m1

(ceusters) #20

I did everything as instructed and it even works when i add the bots separately but the command “exec morebots” doesn’t work…is says that it couldn’t exec morebots or that it is an unknown command…any advice?thanks btw…