What are the HunkMegs suppose to ge set to?


I got a map and i set my hunkmegs up to 72
/com_hunkmegs 72

I want to know what are the standard hunkmegs suppose to be set to. My game lags everytime with these hunkmegs set to 72.

I am running a HP computer 256mb of RDRam 64 mb graphic card a 120 gb hard drive.

(Dies Irae) #2

the hunkmegs with soundmegs and zonemegs are defined for the ammount of memmory used to game, sound and textures

The ammoun of the 3 of em must not be over 3/4 of your total ram

default values for em:

com_hunkmegs “56”
com_soundmegs “8”
com_zonemegs "16

I think the following config can be the best for your ammount of ram:

/seta com_hunkmegs “96”
/seta com_soundmegs “24”
/seta com_zonemegs “32”

(@lewares) #3

I dont really understand all this complicated stuff. If you have a good computer, can you make the game look better by hunkmegs? How do you change these things?

(Dies Irae) #4

Is only to get the game running smoother.

as maybe you know, each program take some memory to itself and other task it do, ET does that, but it only take enough for a good performance. but what happen if you assign more? it works even better :smiley:

how you can use em?
On console type:

/seta com_[what you want to chage] [value]

If i’m right, having more than this config dont do any damage but also any good so call it the max:

Com_hunkmegs 192
com_soundmegs 32
com_zonemegs 32
(192+32+32=256 MB) just for ET. that’s more than 3/4 of the ram for a sys with 256. so use it if you have 384mb or more.

(SCDS_reyalP) #5

In my experience, very large values of hunkmegs either give worse performance (if your system doesn’t have lots of memory), or don’t give any improvement. Assuming you have more than 256 megs of ram, raising it slightly may help. If you have less, it will almost certainly cause more swapping and longer load times. IMO, the 3/4 system RAM rule of thumb is a bit much for low end systems, and following it will likely result in swapping. (laggy gameplay due to HD activity)

Some large custom maps may require a higher value to hunkmegs to run. For servers with lots of slots, you may also have to raise hunkmegs. FWIW, i have 768 megs of ram, and use a hunkmegs of 72. I find that I usually load the map before almost everyone on the server, even though my neither my system no harddrive are pariticularly fast.

Note that the amount of hunk required depends on your detail settings. If you don’t have much memory, use the highest picmip allowed, even if it doesn’t help your FPS much.

Unless you are getting HD activity in gameplay, these settings mostly seem to affect level load times, not FPS.

(@lewares) #6

Err… is 512 MB ram good enough for this?
Com_hunkmegs 192
com_soundmegs 32
com_zonemegs 32

Will it make stuff better or worse?

(pgh) #7

Mmmm all these low mem specs… hugs his 2x512mb DDR 400 PC3500 and Dual Channel DDR/8xAGP mobo :]

Basically. To figure out what the 3 of them should be set at do this.

(MEM/4)x3 = Gives you your maximum ammount that the 3 values should not go above.

With this number, ill name it “B”, you can basically just:

(B/3)x2 = com_hunkmegs.
The other 1/3rd just half it, /2, and use that value for each sound and zone.

Notes about this: Anything over 256 (I think) for com_hunkmegs wont have any more effect on the game than setting it 512.

English basically.

You have 512mb ram. You dont want to use more than 3/4’s of this. So we find out what 3/4’s is so we know not go over it, eg, 3/4’s of 512 = (512/4)x3 being… 384mb. Take this, find out 2/3rd’s and use that for hunkmegs being: 256 which leaves 64 for both sound and zone.

I’d go with these settings:

256 512 1024
hunkmegs 128 256 256
soundmegs 32 64 128
zonemegs 32 64 128

Estimate. Dont know too much detail about the zone/soundmegs so 128 and/or even 64 might not be needed. Just my $2’s :wink:

(Domipheus) #8

i used to always set hunkmegs to 2/3’ds of my total ram, thi above post looks lovely pgh :]

(Pixelated_FooL) #9

I have 256 RD and use 128 hunk, 32 sound, and 24 zone. For some reason, I can never change my zonemegs. I have it in autoexec as 32 and everything but zonemegs changes. When i’m playing and check the /com_zonemegs, i get 24, latched 32. Guess i have to try something different to get that workin :bash:

(Ragnar_40k) #10

Lachted cvars take only effect after a restart. Its locked now, so it doesnt change instantly, but it is scheduled to change on the next start of ET.

(pgh) #11

Just set it, /vid_restart, save it.

(Pixelated_FooL) #12

Lachted cvars take only effect after a restart. Its locked now, so it doesnt change instantly, but it is scheduled to change on the next start of ET.

I’ve tried that, and also done vid_restart 20 million times, its always latched :banghead:

(Billdoe) #13

OK, here is the scoop, on the Hunk, Zone, and Sound Megs.

192 hunk Megs is all ET will use, even if you set it higher.

The Zone and Sound Meg values are both subtracted out of the Hunk Megs, not added to it.

Not surpassing 3/4ths of total memory is easy to figure, 192 is the most memory that ET requires, or will use.

There fore, on a system with 256 Mb of Ram, 192 Hunk Megs, is 3/4ths of the 256.

Systems with more memory would still use 192 Hunk, so on to Sound and zone.

You can use the meminfo command to see the Hunk and Zone usage in the ET console, but Zone is latched, and will only show 24 is used.

If you change this setting in a config file, it will not get changed because the zone Megs are loaded before any config files are run.

To get around this, you can create a short cut, and then add a set command to load the Zone Megs, and Hunk, and Sound as well.

Default settings for Zone and Sound are 24 Megs each, and ET will run with these settings, but those settings were designed for the small RAM of early computers.

The Sound Megs default was set at 24 Mb, and it will work, because ET will remove and reload as needed, but it’s not the best for performance.

To check the sound Megs use the s_info command, and I have found that the best setting for ET Sound Megs, is to set it on about 48 sound Megs, if you use the 22 MHz setting.

We subtract 48 from 192, and that leaves 144 Mb.

Now the Zone is loading Map texture, etc, and please be aware that the higher the quality of graphic settings you use, the more Zone Megs, ET will require.

Also, large servers with 30 to 60 player slots, will also require, more of the left over Hunk, so you may have to play around with the Zone setting, to leave enough Hunk, and remember the Zone has worked, set at 24 Megs, its default setting, for years now.

Therefore, I would recommend 32 to 48 maybe even 64, but it depends on the above variables I mentioned.

So the get the Latched Zone to change, create a short cut, then right click on it, and select properties.

Then in the “Target” text box after ET.exe add this command and put quotation marks surrounding the number value settings, as follows:

"C:\Program Files\Wolfenstein - Enemy Territory\ET.exe +set com_hunkMegs “192” +set com_zoneMegs “32” +set com_soundMegs “48”

I f you find these settings are slower, then just change them, in the short cut, but a word of advice, only change one setting at a time.

Hope this settles the Hunk, Zone, and Sound Meg issues for all you players out there, so enjoy.

Billdoe :armadillochase:

(stealth6) #14

nice stuff!

(Gimpsta) #15

I have 8Gb of RAM so should I set my hunkmegs to 6Gb ?


(Nail) #16

“192 hunk Megs is all ET will use, even if you set it higher.”

miss that part ?

(Gimpsta) #17

[QUOTE=Nail;221905]“192 hunk Megs is all ET will use, even if you set it higher.”

miss that part ?[/QUOTE]

You missed the :wink: at the end of my post … was meant to be a tongue in cheek comment