Weird GtkRadiant issue?

(Bathory) #1

Hello, I am having some weird issue where I try to use the 3D view in GtkRadiant but when I do it spins around uncontrollably and extremely fast. I’ve changed the mouse speed, restarting my computer, uninstalling it, disabling composition and I have searched on Google with no results. A few days ago I was having no problem at all with this, now it just suddenly appears. I’m using GtkRadiant 1.6 and I use Windows 7.

(Indloon) #2

Does it spin when you move your mouse or press some keys?

Or without?

If it appears to be as it is, then one way is to post the issue at Gtkradiant development page:

(Bathory) #3

It spins without moving or doing anything, except for clicking to go into the 3D view.

(Bathory) #4

Does anyone know how to fix it?

(ailmanki) #5

You can also post there:

the issue you have should not be happening… so no idea :smiley:

(obsidian) #6

Mouse model and driver version?
Have you tried a different mouse?
Have you tried disabling mouse acceleration?

@Indloon: The issue tracker isn’t for technical support. You shouldn’t file a bug report when you don’t yet know if this issue is actually a bug or a configuration/hardware issue. We don’t have all the details of the problem yet so filing a report is a little premature. Someone will just end up filing the issue as “works for me”.

(Bathory) #7

The first thing I did was change the mouse and disable mouse acceleration. My mouse model is SWOP-3 and my mouse driver version is 6.1.7600.16385.

(ailmanki) #8

do you got the latest GTKRadiant 1.6.2 ? or an older 1.6x version?

(Bathory) #9

I have the latest, I’ve also tried previous versions but the same thing happens.

(ailmanki) #10

Which gfx card you got? and when did you last update them? Might also be done through windows update.

(Bathory) #11

I’m using ATI Radeon HD 5700 Series and it’s up to date, I don’t think it’s relevant to my hardware since this has only recently occurred and has never happened before.

(ailmanki) #12

Do you have more then one monitor?
If so try using it on your primary, or even disable the other one - for testing.

Its difficult, it could be anything - you could have even catched a virus, not likely - but possible. I mean it did work, and does suddenly not , there has to be some reason or your bits where unluckily hit by cosmic rays.

(Loffy) #13

Sounds really wierd, and annoying. Testing another mouse should fix it, but u have tried that.

I hope it gets better.

(DarkangelUK) #14

Tried loading GTK in compatibility mode?

(Bathory) #15

Yes, tried that.

(Bathory) #16

Well I guess I’ll use the keys for now, thanks everyone for your help.

(S4T4N) #17

I have just recently gotten back into Quake & want to map again - I had the exact same issue with my PC & it seems to be a common issue. 1.4 & 1.5 Glitch the screen out, while 1.6.x workedOK at first…it soon developed the same issue. My solution was to make myPC dual-boot to XP or WIN7. Under XP 1.4 & 1.5 perfectly!! 1.6 Needs some drivers or something won’t run ATM. HOPE THIS HELPS SSOMEONE!! >8)