(Pinibear) #1

Australian Player here. Every-time I try to join an international server it either does not connect or joins an empty room or room with hardly anyone in it like 2-3 players. If I use the auto find game it just take me to an empty room. I’ve flushed DNS, I changed DNS. I’ve tried DX9 and 11, to see if that would work. I have 9 down and .80mps up with telstra. Puzzled why this is happening. anyone found a solution or work around. i72600k GTX950ti 16GB and SSD.

(Meetrock) #2

It has nothing to do with your internet or computer specs. It’s SD’s problem, they fucked up since the v1.0 release and they haven’t fixed it yet.

(Pinibear) #3

any idea when they’re going to fix it.

(kittz0r) #4

or never, depending how many “maybe” fixes it takes

(Pinibear) #5

Hope they fix it.

(Meetrock) #6

When they decide that our experiences are more important than implementing features (which is ironic, they have a UX Designer who probably does nothing)

(Pinibear) #7

Great, still not fixed!!! what happened to Wednesday?

(Mc1412013) #8

Thought every one went to that new gears game and left almost on dirty bomb

(Meetrock) #9

That could be possible.