Rubberbanding/teleporting even though my ping is fine?

(ImSploosh) #1

I’ve had this problem since late 2016. It was after an update back then that caused terrible issues with rubberbanding. However, it was mostly just the New York servers that caused this problem. All other U.S. servers seemed okay. Unfortunately, the worst servers were the ones kept so there is no real way around this problem for me. The community servers are giving me the same issue as well now. I was never able to fix this and I have no idea if there is a fix. Other people have mentioned this issue numerous times, but I can’t find a solution.

So I’d like to enjoy DB while it lasts. Does anyone have any idea on how to fix this? It seems like packet loss, but it only happens on DB. All other online games work fine. DB is unplayable at times because of this.

(Press E) #2

I used to have stuff like this. Happened inconsistently between games and servers for me too, but once I switched off wifi and onto ethernet it completely went away, so I’m guessing it must have been packet loss.

Are you on wifi, and have you tried it on ethernet? Because that’s probably your best bet. Otherwise I was never able to find a fix, and I haven’t heard of anyone else who did either

(ImSploosh) #3

Yeah I’m on Wifi. I would definitely be on ethernet if that was a possibility right now, but I’m located too far away from the modem.

That’s the same answer I’ve seen on other threads. Some people had it happening for varying amounts of time and then it just went away. Then there’s others (like me) that still have the problem. It’s just weird because it’s only DB and it has always been ONLY DB that has this problem. The problem even continued after I switched ISPs, wifi adapters, different changes to settings, firewall, etc. The only thing I haven’t tried is port forwarding, but I don’t know where to begin with that when it comes to DB.

(Press E) #4

All games handle their networking differently, so it seems to affect some things more than others.
For me it turned out the walls of my room were really fucking with my wifi signal, and just moving my desktop out of it helped a lot even on the same wifi

Also could you try a powerline adapter or something like that? They’re not too expensive and it would save you having to run an ethernet cable stupidly far. Depends on how your house is wired of course, but it’s what I’m using now and I haven’t had any problems with it since

(K1X455) #5

If you’re more than 95m away from the modem, it’s possible you’re too far…

100m is the theoretical maximum length of CAT6A; 90m is still practical, albeit degraded bandwidth.


There’s the issue. Wi-Fi will always give you higher jitter than a wired connection - especially if you’re in an area where all your neighbours have their own Wi-Fi APs broadcasting in the same space, and also if you have other devices on your own network.

Having a “super fast 300Mbps connection” with a 1300Mbps Wireless AP can mean very little for Shooters (like Dirty Bomb), which are less interested in the bandwidth of your connection and more interested in the quality of your connection.

If you absolutely cannot get a wire between your modem and your gaming setup, there are a few things you might be able to try to make your gaming experience suck a bit less over Wi-Fi…

Download a Wi-Fi Analyser. There are versions for Android and Windows. Use one to see what channels your neighbours are using. A lot of cheaper APs will default to channel 6. Find a channel that your neighbours aren’t using - if they’re all sitting on Channels 1 to 6, then set your AP to Channel 11.

Or, as suggested by @STARRYSOCK, if your modem/router and computer are on the same ring main, you might be able to use a pair of “Powerline adapters”. They’re not quite as good as a wire, but they’re usually more reliable than a Wi-Fi connection.

Let us know how you get on!

(fzl) #7

get a cable and all works fine!!!

(Mustang) #8

Spot the Brit :octopus:


Copper was expensive back in the good ol’ days.

(ASD) #10

copper > wet cotton > air
no way around

(ImSploosh) #11

I understand. It was just odd how it’s only DB that has ever done this and it only started happening after an update in like late 2016 or 2017. Could be a weird coincidence, but I’m not sure. Figured maybe it had something to do with the ports, kinda like how it is for some console games.

I have previously tried switching the channels and unfortunately, it didn’t help. I’ll keep investigating some more. I’ll also look into the powerline adapters and such.

Tomorrow or sometime this week, I’ll try to move my computer next to my modem/router and test it on ethernet and see how it goes.


Let us know how it goes. If you do find a solution that works for you, then your findings might help someone else in future!