Nuclear Winter Update - Bug Megathread

(Chris Mullins) #1

Hey all!

With every new update there are often a number of unforeseen issues that sneak in. To address these as quickly as possible, we’re creating a single Forum Megathread so you can let us know when you run into them. This way, you’ll have a much greater chance of having them seen by our QA team than by creating a new thread (we only have so much time for bug-thread hunting!)

Before you make a post please do a quick check to see if anyone else has reported the issue you have experienced. If so, simply up-vote their comment and we’ll know the severity of issues.

Format bug reports: When putting a bug into the comments below make sure that you give us as much information as you can. If you can remember any of the events leading up to the issue it can help us find the cause quicker.

  • Type of Bug: Eg. Gameplay bug, HUD and in game UI, Frontend UI etc.

  • Description: Describe what the bug is and what happened in the moments leading up to and after the incident.

  • Video / Screenshot: If you can grab a screenshot (which you can do through steam) or a video recording of the issue it would be useful for us.

  • Steps to reproduce: List the steps that lead up to the bug. Try not to leave any information out, every step can be useful!

  • Result: What happened after you experienced the bug.

  • Expected result: What you believe should have happened if there was no bug.

  • Reproduction rate: How many times out of 10 have you experienced this issue? (1/10 - 10/10)

Copy the below code and use it to fill in your details:

* **Type of Bug:**

* **Description:**

* **Video / Screenshot:**

* **Steps to reproduce:**

* **Result:**

* **Expected result:**

* **Reproduction rate:**

Performance/Graphical Issues: If you are experiencing either performance or graphical related issues, please also add your System Specification to your bug report including: Processor, Graphics Card, RAM, HDD/SSD, Motherboard, Sound Card and even drivers etc.

We’ll be going through each and every bug which is posted here. If you don’t get a reply, don’t worry. Just rest assured knowing we have made note of your issue and it will be addressed when possible.

Thank you for helping us make Dirty Bomb a cleaner place (that sounds wrong but you know what I mean).

(frostyvampire) #2
  • Type of Bug: Gameplay

  • Description: Every time when firing the FEL-IX, there is a delay of about half a second where you cannot weapon switch. It may not seem like much but it got me killed at least twice in my last game.
    This is worse than the bug where you can’t weapon switch after firing the last bullet in the clip with any shotgun and bolt action sniper rifle because it happens after every shot.

  • Video / Screenshot: I can’t really provide a video because I also need to record my hands showing that I’m pressing 3 (the keybind to switch to knife) and/or trying to use the mousewheel to weapon switch and that’s just too much effort.

  • Steps to reproduce: Go Aimee with a FEL-IX, fire a shot. Also it’s worth testing with Vassili just in case to see if it’s weapon related or merc related. The MoA seems to be fine

  • Result: I wasn’t able to weapon switch after firing the shot for about half a second, which matters a lot because you can’t try to escape or switch to your pistol to finish off the target fast enough and could easily get you killed

  • Expected result: Being able to weapon switch instantly after firing the shot

  • Reproduction rate: 10/10

(OwynTyler) #3
  • Type of Bug: Gameplay

  • Description: iron sight toggle setting does not affect iron sight of Rhinos minigun

  • Video / Screenshot:

  • Steps to reproduce: set this setting on, go Rhino, pick minigun, iron sight

  • Result: it’s not in toggle mode but instead you have to hold it

  • Expected result: it should be in toggle mode

  • Reproduction rate: 10/10

(ImSploosh) #4
  • Type of Bug:
    No sound on Pumpkin trinket

  • Description:
    The laughing that should be heard by the pumpkin trinket is no longer there. I tested the Hexadic trinket, and that sound is still there, just not on the Halloween one.

  • Steps to reproduce:
    Equip Halloween trinket.
    Go in-game.
    Press G to inspect weapon.

  • Result:
    No sound heard, animation still plays.

  • Expected result:
    Laughing should be heard.

  • Reproduction rate:

(Meerkats) #5
  • Type of Bug:
    Front end UI.
  • Description:
    Dapper Doge trinket preview does not have “inspect” button. Clicking where “inspect” button should be will still play animation. Animation clips out of view port and has elements that are partially cropped out.
  • Steps to reproduce:
    Preview trinket.
  • Result:
    …I mean… this is what a “description” is, is it not?
  • Expected result:
    There should be a button. I am assuming the animation is not supposed to clip out of view.
  • Reproduction rate:
  • Comments:
    Was just watching Lightningzor stream, and while he also doesn’t have the “inspect” button, when he inspects, he can see the full text. We are both playing on 1920 x 1080 resolution.

(K1X455) #6

Do you know what a “Cancel” button does?

(n-x) #7

Type of Bug: Steam achievements nurse 2 & 3 dont work for Phoenix
Description: Health units given with Phoenix dont add to the nurse 2 & 3 achivements. This was already the case for the Nurse “1” achievement 1.5 years ago!
Steps to reproduce: Play with Phoenix and heal other mercs!
Result: No progress on the achievements.
Expected result: Progress on the achievements.
Reproduction rate: 10/10

(Jigstraw) #8

Type of Bug: Weapon bug. Particularly the Remburg shotgun.

Description: I don’t use shotguns much, but as you’ve added new steam achievements, I’ve been trying to make use of my R51 Jackal’s Eve Proxy with the Remburg, the DE.50, and the quickdraw augment. The problem is if you fire the Remburg, and immediately try to swap to your secondary, the game will automatically swap back to the Remburg and finish the animation of pumping to chamber a fresh shell without allowing you to fire your secondary at all. This does not happen with the Hollunds or Ahnuhld, only the Remburg.

Video / Screenshot: It’s a fairly easy bug to recreate and test, I don’t think evidence is necessary.

Steps to reproduce: Hit mouse1 immediately followed by the scrollwheel or number key to change weapons.

Result: You switch weapons and are then forced to switch back, complete the pump action animation, and try again to switch weapons if you’re not dead.

Expected result: Shoot, switch weapons successfully without interruption.

Reproduction rate: It seems like a fairly common issue. I couldn’t put a number to it so i’ll just go with a median 5/10

(OwynTyler) #9
  • Type of Bug: game server crash

  • Description: played a game, then it wrote “connection lost” (for everyone, I know that cuz I was playing with friends in Voice chat) and server just dissapeared from server list, happened at least few times to me in the past few days

  • Video / Screenshot: -

  • Steps to reproduce: play, wait for server to crash

  • Result: server dead

  • Expected result: server alive

  • Reproduction rate: 1/20

(DMaster2) #10

Just returned after 3 months, may i ask why everything in the menus is laggy now?

(azz_abdr) #11

I know this bug has been reported so many times but still no fix:

Mines cannot be destroyed by stickies or nades.

(Ceepert) #12

Type of Bug: Eg. Gameplay bug

Description: When playing Fragger on Underground you can get above the map out of bounds.

Steps to reproduce: At the first escelators on the left side viewed from the defending spawn, if you time a grenade right so it exploses right after throwing and jump of the top of the escelator down to the elevator the grenade pushes you up, pushing you though the roof that doesnt have a hitbox it seems like. This allows you to walk above the map to the last c4 spot and camp above it.

Result: You are ontop of the map. Noone will suspect you there. Realy unfair and it happened in Ranked too.

Expected result: Dont go through a roof.

Reproduction rate: 10/10 if you know how to time the nade.

(K1X455) #13

This has been going on lately

(Major_Slapnuts) #14

the event ended 1 day early.

The festive season is finally upon us and while most of us are wrapping up for the cold nights ahead, London’s Mercs still aren’t getting a Winter break!

Today is January 4th. Today should be the last day?

(Nail) #15

nope, time zones are relevant, even on line

(K1X455) #16

@K1X455 said:
Do you know what a “Cancel” button does?

(supersonic_ht) #17
  • Type of Bug: Merc ability bug (or at least UI, not verified)

  • Description: Proxy mine count got reset in spite of mine being deployed: I was playing Trainyard on an Asia pub server 3 days ago. I had placed a mine by the generator during the 2nd objective and died at some point. During the respawn time, the objective was completed and my mine count on the UI was reset. However, I hadn’t tried to place 2 more mines to check if I could, so I’m not sure whether it was a mechanics issue or just a UI bug.

  • Video / Screenshot:

    Notice the mine in the middle of the screen and the UI indicator to the right showing I have 2 mines left.

  • Steps to reproduce: I haven’t been able to reproduce it due to the set of circumstances that need to happen together, but I suppose the steps would be: die after placing a mine and have the objective complete while you’re still in respawn.

  • Result: Mine count on UI resets to 0 while mine(s) still exists on the map.

  • Expected result: Mine count is unchanged.

  • Reproduction rate: 1/10 due to complex set of circumstances.

(supersonic_ht) #18

@supersonic_ht said:
I was playing Chapel pub on an Asia server yesterday; a team shuffle was passed and I was killed just before the countdown ended. As a result, when shuffle completed and I got moved to the other team, I was able to see the red silhouette of my killer in spite of being alive. The silhouette persisted for that life, and when I died, the camera moved to the place of my last death (pre-shuffle), showed the same red silhouette and a dummy player model in place of where my body must have been during the previous death.


Copied from:

Notice in the screenshot that the killer is a Kira while the silhouette is of Sparks (I think) who I was killed by in the last life.

  • Steps for reproduction: Get killed, respawn (automatically) after a shuffle vote is passed and you are put on the other team.

  • Result: Red silhouette of killer persists in your next life. When you die again, a dummy player model (with a mohawk, I presume) is shown where your previous corpse was.

  • Expected result: No persisting silhouette, no dummy player model with a mohawk.

  • Reproduction rate: The set of circumstances has happened to me only once, but I’ll try to reproduce it and put a number here.

(Meerkats) #19
  • Type of Bug:
  • Description:
    Timik-47 w/ Nuclear Winter skin has extremely bright muzzle flash, illuminating entire rifle causing a painful, seizure inducing, strobing effect.
  • Steps to reproduce:
    Shoot gun.
  • Result:
    Painful strobing.
  • Expected result:
    Normal muzzle flash?
  • Reproduction rate:
  • Comments:
    Attempted to reproduce with a Nuclear Winter loadout w/ Timik-47, but could not get same effect. Suspect may be tied to applying Nuclear Winter Timik-47 skin separately, but I do not have this skin ( I’ll take donations though! ) to test with. Do not know how many weapons are affected by this bug, but appears to be limited to Timik-47.
    Twitch clip:

(designandres) #20