New update help: Detplock Trojan?


(boerhae) #1

https://www.microsoft.com/en-us/wdsi/threats/malware-encyclopedia-description?name=Trojan%3AWin32%2FDetplock&threatid=2147680291

I consistently get this from Windows Defender when attempting to install the new update (8/7/18) [look at the file path in the image, that’s DB]. Canceling and restarting the update reinstalls Detplock with it

Is this safe?? What should I do? Has anyone else encountered it?


(DarkangelUK) #2

I use Windows Defender and I haven’t had that flagging up for me, could be you’re already infected with something that’s corrupting the files? Maybe best run malwarebytes scan etc.


(STARRYSOCK) #3

Have a friend who couldn’t launch the game after the update because Easy Anticheat flagged Dockyard’s map file for something. I think the devs just messed up the recent update.

I haven’t had an issue with Windows Defender or Avast tho


(boerhae) #4

To be honest I think my copy of DB is just screwed, I wasn’t able to start the game all day because the update would get to 100% and then start over. I finally fixed that and now this is a thing

I might just try a reinstall.


(STARRYSOCK) #5

Try verifying the game cache through steam first, much faster lol


(henki000) #6

Just to be completely sure that Trojan is gone. Did you scan in safe mode? Have you monitored network activity for suspicious traffic?


(boerhae) #7

@STARRYSOCK Already tried, didn’t work; reinstall didn’t work either.

To clarify,

@DarkangelUK I get another notification about the Detplock trojan each time I try (and fail) to run the game. EAC’s launcher says my ‘game executable is invalid.’ Malwarebytes didn’t pick it up.

Edit: the filepath in the error …Binaries/Win64/shootergame-win32-shipping.exe does not exist. I have no idea wtf is happening anymore, the game was fine yesterday.


(HadronZodiac) #8

Im getting a file 32 issue

“CreateFile failed with 32” so idk if these are connected lol


(boerhae) #9

Try running Steam as an administrator. https://steamcommunity.com/app/333930/discussions/0/1291816880500340097/

Isn’t fixing my issue but yours was mentioned so I guess it’d be worth a shot

Edit: Reinstalling distribulties or however you spell it, like it was mentioned in that thread, solved my issue. phew Now it’s time to go fail another team!


I am experiencing a file 32 issue. and cant play D:
(ASD) #10

here the same… no issues with my defender