Jackal's Eve Update - Bug Megathread

(Chris Mullins) #1

Hey all!

With every new update there are often a number of unforeseen issues that sneak in. To address these as quickly as possible, we’re creating a single Forum Megathread so you can let us know when you run into them. This way, you’ll have a much greater chance of having them seen by our QA team than by creating a new thread (we only have so much time for bug-thread hunting!)

Before you make a post please do a quick check to see if anyone else has reported the issue you have experienced. If so, simply up-vote their comment and we’ll know the severity of issues.

Format bug reports: When putting a bug into the comments below make sure that you give us as much information as you can. If you can remember any of the events leading up to the issue it can help us find the cause quicker.

  • Type of Bug: Eg. Gameplay bug, HUD and in game UI, Frontend UI etc.

  • Description: Describe what the bug is and what happened in the moments leading up to and after the incident.

  • Video / Screenshot: If you can grab a screenshot (which you can do through steam) or a video recording of the issue it would be useful for us.

  • Steps to reproduce: List the steps that lead up to the bug. Try not to leave any information out, every step can be useful!

  • Result: What happened after you experienced the bug.

  • Expected result: What you believe should have happened if there was no bug.

  • Reproduction rate: How many times out of 10 have you experienced this issue? (1/10 - 10/10)

Copy the below code and use it to fill in your details:

* **Type of Bug:**

* **Description:**

* **Video / Screenshot:**

* **Steps to reproduce:**

* **Result:**

* **Expected result:**

* **Reproduction rate:**

Performance/Graphical Issues: If you are experiencing either performance or graphical related issues, please also add your System Specification to your bug report including: Processor, Graphics Card, RAM, HDD/SSD, Motherboard, Sound Card and even drivers etc.

We’ll be going through each and every bug which is posted here. If you don’t get a reply, don’t worry. Just rest assured knowing we have made note of your issue and it will be addressed when possible.

Thank you for helping us make Dirty Bomb a cleaner place (that sounds wrong but you know what I mean).

(Jaso) #2

as u can see some bugs with items icons

missing image of Detective Case (Amies one from RoV event), Culprit & Special Edition Culprit Case showing locked

(azz_abdr) #3

On Vault as attacker, I was using Turtle. There is 2 times I can’t reclaim my shield, I disable the overlay so I can’t take screenshot and Windows screenshot didn’t work.

So to explain this, the first one is beside the wall near AA tank that facing balcony/mg, I deploy it, maybe it takes a few bullets but not destroyed, my shield still on cooldown so it’s been not too long deployed. There is no “press f to reclaim” and if I press f it’s not reclaimed.

The second time is on alley (the one under buildings) near container (last objective), I place it maybe about 5s and didn’t take any damage, I want to move it to protect the carrier so he can deliver it, there is no reclaim option again.

(K1X455) #4
  • Type of Bug: Gameplay

  • Description: Objective Badges not being awarded

  • Video / Screenshot: n/a

  • Steps to reproduce: 1. Play Chapel or Bridge 2. Deliver cores

  • Result: Missing badges, incomplete missions

  • Expected result: objective badges, mission accomplishment

  • Reproduction rate: 7 of 8

(Melinder) #5

Which badges in particular are you referring to? I just tested your theory and received the following badges.

(K1X455) #6

I think (and that is a theory) that:

  1. Repairing the EV first time around gets you Bronze
  2. Completing the EV escort gets you Silver
  3. Failing to deliver the first core but managing to deliver the 2nd one entitles you for a third Gold Badge.

In this GPV @ 27:40, I completed the EV escort which gave me the first objective badge; subsequently, I delivered the first core which won the match but it did not award a silver badge.

(emjot) #7
  • Type of Bug: Map Selection (Casual)

  • Description: I was able to get 4 deselections (probably old data before update since I don’t play casual recently)

  • Video / Screenshot: https://imgur.com/a/4lSkT

  • Steps to reproduce: n/a

  • Result: 4 deselection

  • Expected result: can’t queue with 4 deselections

  • Reproduction rate: 10/10

(MaceyKeys) #8

I’ve been in the middle of a ranked match and was disconnected. When I tried to rejoin i wasn’t prompted to rejoin and wasn’t penalized for being disconnected like normally in the past. I went on my merry way while i’m sure my team mates suffered.

(MaceyKeys) #9

There’s a bug that’s been happening prior to the jackal update.

When you are reparing the ev while strafing you will be whipped around the EV so fast that you end up over shooting where you want stop and repair.

(azz_abdr) #10

in case you miss this:

mine hitreg with explosive bug

(BBBadger) #11
  • Type of Bug: Augment Loadout information

  • Description: Ranked Season 4 patch changed Javelin’s Ammo Reach augment to a 25% increase to its radius. Currently, it only shows 15% in Javelin’s loadout card with the Ammo Reach augment.

  • Video / Screenshot:

  • Steps to reproduce: View any loadout with Javelin’s Ammo reach augment

  • Result: Displays 15% increased radius

  • Expected result: Should be 25% increase, as stated in the Ranked season 4 patch notes

  • Reproduction rate: 100% ?

(Jaso) #12

@Jaso said:
as u can see some bugs with items icons

missing image of Detective Case (Amies one from RoV event), Culprit & Special Edition Culprit Case showing locked

@stayfreshshoe any news about the fix …still not working!

(azz_abdr) #13

@BBBadger said:

  • Description: Ranked Season 4 patch changed Javelin’s Ammo Reach augment to a 25% increase to its radius. Currently, it only shows 15% in Javelin’s loadout card with the Ammo Reach augment.
    There is still some description hasn’t been updated, recharge is also 15% now not 10%.

(Melinder) #14


Now I have put this in the Bug Megathread as I am unsure as to whether or not this is a bug or a terrible design choice, though judging by the response I received from a Support Ticket, I am lead to presume the latter is true.

I think it’s pretty ridiculous that you aren’t able to restart Dirty Bomb in a Ranked match without being instantly penalized and receiving a loss as soon as you type “Exit” in the console.

This is a massive design flaw, especially when there is currently an issue with Dirty Bomb randomly causing insane FPS drops to as low as 20, where restarting Dirty Bomb is the only way to fix it, which, as I mentioned, leads to you being given a loss for the match and receiving a penalty the instant you close the game.

As well as this, as we all know, the Internet isn’t perfect, and disconnections can and will occur. Receiving a loss and a penalty for lagging out, even if it’s only for 30 seconds, is actually retarded.

If the “lagging out” instance doesn’t lead to a penalty, then I have to ask: Have you coded the system to automatically penalize players who manually type “Exit” in the console assuming they’re rage quitting?

(Melinder) #15

“Crosshair Dot When Sighted” option is off-centre depending on what Mercenary you’re playing.

(xNeptune) #16
  • Type of Bug: Missions Section

  • Description: Missions section display an error Icon instead of missions. Cannot receive any missions.

  • Video / Screenshot:

  • Steps to reproduce: No idea. One day I just completed my missions and then I got this error icon when they were supposed to reset.

(dgeesio) #17

since latest build i always get a whitescreen as dirty bomb starts up.so does my son.never done this previous only with the latest build of dirty bomb.

(Xenithos) #18

There’s a bug about where high ranking golds are having a very hard time ranking up. Might be related to no losses or very small amounts of matches played. Insight on this problem is requested if it’s a deliberate function, http://forums.dirtybomb.com/discussion/38418/rip-cobalt-dream#latest for better information.

  • Type of Bug: Audio

  • Description: Guardian has no death scream

  • Video / Screenshot: Just… go play her. She has none when being downed.

  • Steps to reproduce: Die as Guardian, or listen to the blank sound of no Guardian death scream as your fellow Guardian dies.

  • Result: You hear no Guardian BLAUGH

  • Expected result: Guardian go Bleh

  • Reproduction rate: 10/10 Doesn’t seem to exist.