Getting a Mod Running.

(-xXx-Suicide) #21


I have all my files as above in the “mymod” directory

I start a pure server
Try to connect a client (the computer next to me on my LAN,) and it gets

“Couldn’t load an official pak file; verify updated…”

Is there some way to make the server say “yo! use this file!” from my machine?


(Chruker) #22

Is the .pk3 download system disabled on the server and/or client?

(-xXx-Suicide) #23

It is enabled on both.

(Chruker) #24

Are both machines running the same version of the ET executable (.exe)?

Are the pk3 files present?

How do you start the client? Which command line?

(Rain) #25

The “couldn’t load an official pak file…” message means that a file named pak#.pk3 was referenced on the server, but couldn’t be found on the client. Since some rather…misguided server admins have named their campaign pk3s things like pak95273.pk3, this can be a major pain in the ass (especially since ET isn’t good enough to tell you which pk3 was the issue.)

(-xXx-Suicide) #26

All files on client and server are the same, same version of ET (even installed from same files,) et al.
Starting server from fs_game xxxmod; tried client both normally, and with the fs_game command.
Also put files on client manually, and it still fails pure check.
What makes a PK3 official? What tells the client in a pure situation “hey, I’m using the files from xxxmod.pk3, download that!”? In unpure, it downloads and works just fine.

(Rain) #27

“Official” = named pak####.pk3 or mp_bin.pk3 and referenced by server.
Required on client = named anything, referenced by the server (listed in sv_referencedPakNames.)
Usable on the client, but not required = named anything, exists on the server (listed in sv_pakNames.)

(-xXx-Suicide) #28

That sheads some light on it.

Thank you!

(-xXx-Suicide) #29

In short, it was a defective carbon-based unit fouling it all up.
I forgot I was playing with 000.pk3 to see if I could change a few things
Copied the original from one box to the other, shazam! Pure server up and running correctly!

(freebsd04) #30

New Fresh Problem

Can anyone help with a CONS related problem I’ve been getting. I’ve tried to work it out myself, but I’ve spent so much time on it, I need other angles to attack this from.
Firstly I am trying to compile the ET source under freebsd 4.10-release.
I have gcc 2.95.4. I am relatively new to this, so I apologise in advance if I ask a stupid question. I have tried to solve the problem myself but can’t. I’ve read the Compiling a mod under GNU/Linux post which is how i’ve ended up here.
The only real change I’ve made from the original is adding the path of perl ( /usr/bin/perl) in the CONS file. Then I type

>./cons – release

which gives me the following:

/lib/ not found
cat: …/game/q_shared.h: No such file or directory
Enemy Territory version
cpu : x86
OS : FreeBSD
configured for release build, in directory release-x86-FreeBSD-
CFLAGS: -pipe -fsigned-char -DMISSIONPACK -DNDEBUG -O6 -mcpu=pentiumpro -march=pentium -fomit-frame-pointer -ffast-math -fno-strict-aliasing -fstrength-reduce -malign-loops=2 -malign-jumps=2 -malign-functions=2
Ignoring missing script “/home/src/extractfuncs/Conscript” (script::Build in Construct, line 334) at ./cons line 749.
Ignoring missing script “/home/buser/unix/Conscript-game” (script::Build in Construct, line 393) at ./cons line 749.
Ignoring missing script “/home/src/unix/Conscript-cgame” (script::Build in Construct, line 409) at ./cons line 749.
Ignoring missing script “/home/src/unix/Conscript-ui” (script::Build in Construct, line 420) at ./cons line 749.
cons: don’t know how to construct “release-x86-FreeBSD-/out”

I think it might be because of the unzip command not maintaining the directory structure. Is there a way I can unzip and maintain the dir structure in freebsd?

Or any suggestions/advice?

(Frosty) #31

I am having some problems with running my mod on Gentoo Linux. I have ET 2.56, GCC 3.4 and Libc2.3. Conscript is set to use GCC3.
Running ./conscript – release gives me a message about missing the extractfuncs/Conscript script. Is this important? It seems to build anyway.

I installed the files in my ~/.etwolf folder under frostet(so creative) like this:


I stuck all of the files into a mp_bin.pk3 and a frostet-0.pk3. I have also tried pak12321.pk3.

Upon starting a listen server, the game attempts to replace my I tried changing the file permissions arround, and now it says that it failed to remove the outdated ~/.etwolf/frostet/ It does not attempt to change any other files, and I can run server side only stuff.

I am using the command line “et +set fs_game frostet +set fs_homepath ~/.etwolf +set fs_basepath /opt/enemy-territory”

What is wrong?

Note: all ~'s are really my home directory path.

EDIT: or maybe it is that I can only run client side mods? I’m not sure. I know that I have sucessfully changed the death messages some.

EDIT again: It seems to be working now. I think it had something to do with having only the Linux libraries in the directory.

(Alan) #32

to compile et under linux :

cd my_path/WET_Source/src/unix
perl cons -- release gcc3

You should install the .so files into the “global” folder (ex: /usr/local/games/enemy-territory/mymod) because et overwrites the ~/.etwolf/mymod/.so files by the original etmain *.so.

to launch et :

et +set fs_game mymod +set sv_pure 0

Voilà , :slight_smile:


(SCDS_reyalP) #33

You do not need to set sv_pure 0 to run a mod, assuming you have correctly created mp_bin.pk3


okay im trying to download this SS skin pack by vlasterx and this is what i’ve got it under.
C:\Documents and Settings\Owner\Local Settings\Temporary Internet Files\Content.IE5\KJ23W3WH\ss_skinpack_v1[1]

okay. now i dont understand that mumbo jumbo stuff about the files so i dont know what to do. it says put it in your et main folder, but i dont understand that. :moo:
can someone tell me the what to put in the extraction wizard thing? im only 9 so i dont get it

(P4nth3r) #35

Hi, I’m using MS Visual Studio 2006 to compile, but after my compile is done I have 3 .dll files and 3 .ilk files.
But I need .so files for ET.
I don’t know why he is making ilk files out of them, are they the same or something??

Greetz Panther aka Way2Evil

(kamikazee) #36

The ilk files could be temporary build files but in the worst case it are special files to which the dll’s refer.
I’m not sure if you can actually compile a mod with VS 2005, I allways did it with VC++ 6. (As it can build C code as well)
Just throw the .dll files without the ilk files inside a new folder in your Wolfenstein dir (Not in etmain!) and start ET with

+set sv_pure 0 + set fs_game <yourfoldername>

If it doesn’t crash the instant you load a map, you may have a working mod. :smiley:

If you need .so files, you need to ask someone else using Linux, I’ve got it set up under Gentoo.

(P4nth3r) #37

Well I compiled it with MSV2006 and put the files into the right map etc and compressed the mp_bin.pk3 and it worked fine.

(nUllSkillZ) #38

.dll files are Windows files.
Where as you need .so files under linux.

(P4nth3r) #39

hmmm, so my mod probably won’t work under linux? =(

(FREAK!!!) #40