Forced to check file integrity on every lauch,game file getting corrupted

(Spykiller91) #1

i’m having this problem where my DB does not start when i launch it for first time, then i have to go into steam file integrity check thingy, which always says some file got corrupt and always downloads about 12mb. after that i can run the completely normal until i close the steam. i dont have have antivirus currently,so its not antivirus that might be messing up things.
[screenshots added]
its not download data that annoys me but that file checking thing eats like 10mins of time. i haven’t found any solution for it except for file checker, which does not fix it permanently. files are getting corrupt repeatedly. i have core2duo 2.93Ghz,6gb ram,r7 240 1gb ddr5, win7 64bit.i get decent close to 60fps on lowest settings.
i hope i’m not missing something obvious,please help.
thank you,great game, deserves bigger player base.

(Mustang) #2

These are the checksums for libeay32.dll v1.0.1.3 that should be located at “<install path>\steamapps\common\Dirty Bomb\Binaries\Win32”:

    File: libeay32.dll
  CRC-32: af59d768
     MD5: d4668be5b33f8d8065b15ef7c2b92c09
   SHA-1: dea5aca9f632ef2a64f6c99bbe729d430a54993f
 SHA-256: 946b40b8f3d28a71297127c97ffd2d0f25a66f0c057467a569ca5e04904b6488
 SHA-512: 51c34a83fb41640babe6f80ed5e3b7f5625cb618d3c3868fd9db42cb07d12f33e181539097583127b5a62a09cbe16f983f8bf1c45988af9194f0f37b3b8f42b8

Maybe it helps to confirm your file/version is correct.

Here are some things you can try that might help: Tips to fixing wierd problems

If all else fails try uninstalling and install from scratch again.

(Spykiller91) #3

forgive me for coming back here late, i tired everything else except for the first thing you said, i dont know what you wanted me to do.i’m noob,please explain. file version is exact same as you said.
i located that file, deleted it, delete other files too, then checked file integrity and it downloaded the game amount of data, it worked fine for 1 day.
tried full reinstall ,nothing changed. next day when i launch the game screen goes black and error in first pic pops up. i even updated my gfx card now.