ET: Legacy


(Gir) #201

I tried ETL, the Gamma does not work


(7Killer) #202

Hey
First a big grats, what a nice works that this server fix :smiley:
I make a special release of ET:L with multiclient support and integrated facade.
Win and linux build seems works fine ( for the moment, i just try to connect with on the both port and with 2.55 and 2.6 client, and verify its listed on the both list)).Only IPV4 is support on facade port.
I try to work of a compilation chain which allow us to runs et:L on gameservers but for the moement its a fail ( ****ing libc).
I searching some server to make test (if interrest Pm plz)
And if ET:L is interrested to merge this into their code simply ask for it.
Let me know what u think fo that


(Paul) #203

[QUOTE=7Killer;400420]Hey
First a big grats, what a nice works that this server fix :smiley:
I make a special release of ET:L with multiclient support and integrated facade.
Win and linux build seems works fine ( for the moment, i just try to connect with on the both port and with 2.55 and 2.6 client, and verify its listed on the both list)).Only IPV4 is support on facade port.
I try to work of a compilation chain which allow us to runs et:L on gameservers but for the moement its a fail ( ****ing libc).
I searching some server to make test (if interrest Pm plz)
And if ET:L is interrested to merge this into their code simply ask for it.
Let me know what u think fo that[/QUOTE]

I already made this. It will not be included in ET:L because IRATA does NOT want any 2.55 support (which isn’t so weird after all).

Also note to not release any server related ET:L at this moment. It gives a lot of trouble with many mods, servers will stay empty :frowning:

Catch me on xfire allright :)?


(7Killer) #204

Yeah i know, but IRATA ( even if i have a lot of respect for him) is the only voice…
So its for sure, that 2.55 clients are wierd but they represent a amount of peeps we can’t forgot in my eyes, simply because a lot of new clients just install 2.55 and make not update…
I have a plan to update client to update but that require a lot of time code i haven’t, so i couldn’t said i can apply it a day but in a first time, splash the 2.55 client and invite them to update to 2.6 can be make asap.
For sure, 2.55 clients can be connect to nq mod if they didn’t update.

For sure but without real test , et:l team can fix it too :frowning:
I try with lastest nitmod (2.2final) and my old mod ecsmod without any problems, so its true that i just have bots into 95 % of time.
In all case, in a first time , i ll make a version with a special version number so they can detect, and if u make request, i ll shutdown trackbase service in my version.

Catch me on xfire allright :)?

will be done asap :wink:


(Dragonji) #205

Wow, it means it will be a fail after stable version is released… Only some NQ servers will use ET:L server binary.

I hope source will be released so community will be able to add multipatch support on their own :slight_smile:


(Radegast) #206

This is how we want the 2.55 clients to be handled:

…and there will be a short url with ET:L installer in that message. More info about this.

Exactly! It is true that ET:L dedicated server is not bug-free, but if people won’t test it and report any issues they encounter then we’ll never be able release a stable version. There were two main issues in the last release. First was wrong use of NET_AddrToStringwPort and second was sv_timeout set to a low value. Please make sure that you set sv_timeout to 240 on your server.


(Gir) #207

One Request

sv_fps should be defaulted to 30


(Dushan) #208

[QUOTE=Gir;400489]One Request

sv_fps should be defaulted to 30[/QUOTE]

why exactly 30?


(Gir) #209

Quake Live defaults at 30


(Dushan) #210

that isnt argument


(Paul) #211

ET engine is designed to run at 20 fps, and you should keep it at that too


(Gir) #212

So, internet speed is much faster then 2004.

Bug: Venom Gun Sound is glitched in NQ123 using ET Legacy


(Gir) #213

Bugs

Sprint Key is a Toggle, should be Hold
Input lag
Sound glitches
Random Crashing
No Gamma Controls


(Mateos) #214

There’s as well an Edit button :slight_smile:


(acQu) #215

Bugs which have all not been there before :frowning:


(Radegast) #216

Sprint Key is a Toggle, should be Hold - huh? It is “Hold”
Input lag - I don’t have any input lag on linux. I’ll test the windows version if there is any difference.
Sound glitches - noted, venom gun and bazooka sound funny. Did you notice any other sound problems?
Random Crashing - hmm, that’s sad. I play a lot with ET:L client and the version from git hasn’t crashed on me yet. Since it is random crashing I don’t know how to help you.
No Gamma Controls - noted, thanks

Again I am grateful for your help, Gir. If you would like to discuss these bugs further, please post to the bug section of our forum or come to #etlegacy at Freenode.


(Nitrox_) #217

Engine’s not designed to run @ 20fps as far as i know, but ET game code is.

If you modify sv_fps value, game code will still assume the engine is running @ 20fps (except on mods that fixed it), and some things will appear unusual (faster or slower than usual depending on sv_fps value).


(morsik) #218

7Killer: 2 of our already built that facade 2 weeks ago. But for now, we are not interested in integrating it into ET:L. We don’t want to support 2.55, but admins want to allow it… strange.


(Mateos) #219

Even if 2.55 isn’t the latest version, since some player just took the original and latest official full installer, they have 2.55… Some play doesn’t seek updates or patches, and some admins run 2.55 or 2.55+.


(cheesy) #220

Respectfully…trying to drop support for 2.55 is pointless for two reasons.

  1. Somebody WILL remove or reverse the code to support 2.55 on anything open source
  2. I agree with 7killer and Mateos. There will always be many 2.55 players because of that original (and the only legit) installer

I understand there are some large clans and developer names that want to do away with 2.55 client support, but as 7killer said, they are NOT the only voice. The amount of 2.55 players per 2.55+ server is greater than the amount of 2.60b players per 2.60b only servers. For those of you who understand the term…this is known as the “silent majority”. These are players that just play ET, and do not argue or put their voice on forums.

Just like Microsoft makes backwards compatible support packs for MS office and applications, there are developers keeping ET compatible with 2.55 version. And as a server owner, I will always chose a binary that is backwards compatible over one that has limitations.