Documentation / Editor Errors

(sock) #1


1. Under Construction System->New Entities->Single Team:

Additional key/values for the flag model: modelscale: 0.4
frame: 0.4 (Total amount of animation frames)
spawnflags: 2 (Start entity animated)

“frame” should be “frames” and value should be 190, not .4

2. Under Construction System->New Entities->Single Team:

Create a rough set of clip brushes which mirror the shape of the construction crates model. Then create an origin brush, select all the previously created clip brushes and converted them into a func_static entity. Select the func_static entity and set the targetname and scriptname keys so that it can be referred to by the script.

Instead, of func_statics, these should be script movers with the solid flag checked. In addition, the script_mover needs a section in the script like so:

        wait 50

Although, I didn’t test without the spawn and death functions. Also, 50 was a value that worked for me, although I imagine it could be slightly more or less.

3. Team_Wolf_Checkpoint missing from entity list. To fix, according to SCDS_reyalP:

The respawn flags, as used in radar, oasis, battery and railgun railgun are this entity. If it is not in the et_entities.def file, you cannot place it using radiant. As a workaround, you can use the definition from RTCW, by adding the following to your et_entities.def

/*QUAKED team_WOLF_checkpoint (.6 .9 .6) (-16 -16 0) (16 16 128) SPAWNPOINT CP_HOLD AXIS_ONLY ALLIED_ONLY 
This is the flagpole players touch in Capture and Hold game scenarios. 

It will call specific trigger funtions in the map script for this object. 
When allies capture, it will call "allied_capture". 
When axis capture, it will call "axis_capture". 

// if spawnpoint flag is set, capture will turn on targeted spawnpoints 
// for capture team and turn *off* targeted spawnpoints for opposing team 

"model"      model to use (will use same animations as flagpole however) 
"scriptname" name of script which contains allied_capture and axis_capture triggers 

4. team_ctf_xxxspawns have a typo in the spawnflags list. “invulnerabe” should be “invulnerable.” The “l” is missing near the end.

Note: As in the current code the “invulnerable” spawn flag does nothing because the player always starts invulerable by default.

5. Health/Ammo Cabinets-> Entity requirements: For the target_objective_info entity, the customimage key needs to be set to gfx/limbo/cm_healthammo, or else a missing shader image will appear. Also:

For each cabinet a rough set of clip brushes will need to be created to mirror the shape of the model. Once all the clip brushes have been created an origin brush will need to be added and then everything converted into a script_mover entity.

This does not apply as the misc_cabinet_xxxx entites provide their own clipping. However, the misc_cabinet entities cannot be roated with accurate clipping. The model will roate, but the clipping will not. You can rotate at 90 degree increments with accurate clipping.

6. trigger_heal default value typo:

“healrate” rate of healing per second, default is 5…

Actual default healrate value is 20, heal default value typo.

7. trigger_relay missing from entity def. file. Not used in any of the existing ET maps but I have test the entity in a small sample map and it appears to work correctly. The RED/BLUE team spawnflag options also work correctly. Not sure about the inventory key spawnflag options because ET does not use inventory keys. Add the following to the existing DEF file or create a new one. - (Sock)

This doesn't perform any actions except fire its targets.
The activator can be forced to be from a certain team.
if RANDOM is checked, only one of the targets will be fired, not all of them
"key" specifies an item you can be carrying that affects the operation of this relay
this key is currently an int (1-16) which matches the id of a key entity (key_key1 = 1, etc)
NOKEY_ONLY means "fire only if I do /not/ have the specified key"
TAKE_KEY removes the key from the players inventory
"lockednoise" specifies a .wav file to play if the relay is used and the player doesn't have the necessary key.
By default this sound is "sound/movers/doors/default_door_locked.wav"
NO_LOCKED_NOISE specifies that it will be silent if activated without proper key

8. func_constructible entity key/value definition is wrong in the TDR. The multistage keys are not specified correctly. The definition should be:

The func_constructible entity has the following keys : 

targetname: The name used in the script for referencing this entity. 
scriptname: The routine name in the script file. 
track: Construction group function. 
wait, score, health: Not used anymore (replaced with script commands). 
constages: List of construction func_brushmodel entities. 
desstages: List of destruction func_brushmodel entities. 

9. The section called “Objective cameras” in the index on the left of the TDR is called " Dual objectives" instead. Wrong title on actual page.

10. The section “Objective cameras” in the TDR talks about linking “info_limbo_camera” entities to “info_null” entities. This should say “info_notnull” entities instead.

11. The “target_speaker” entity has a spawnflag option of “global”. This spawnflag option does not work correctly. It is recommended that people use the ingame speaker editor system documented in the TDR under the section of “Speaker Editor”.

12. OBJFLAGS key /values in TOIs do not work.

13. Not sure if this is an error or not but in the snow.shader file there is this entry.

	surfaceparm alphashadow
	cull none
		map textures/snow/alpha_ice2s.tga
		rgbGen vertex

The shader shows up as a shader not found image in radiant so I put this line in the shader: qer_editorimage textures/snow/alpha_ice2s.tga

14. Documentation error: NEWS REEL docs state:

/sound/vo/<map name>/news_<map name>.wav
Not true - the news reel audio can be anywhere as long as the sound script file points to the .WAV file correctly.

15. Entity .DEF file error: The INFO_LIMBO_CAMERA help states:

“objective” a number starting from 1 possibly going anywhere up to 8, but maybe more later. (only required for objectives, not spawns)
The objective key can also take a value of zero - this corresponds to the default, non-objective view in the limbo screen.

Recommendations / Suggestions

Def Fixes:

EDIT: merged all replies into top thread. 03/Feb/2004

(sock) #2

Merged all replies and comments into top thread. Only post comments regarding documentation.


(Chruker) #3

In Appendix A: Scripting Commands under ‘Trains, splines and animations’ shouldn’t the last command be setstate instead of setposition?

setposition <targetname> <default|invisible|underconstruction>
Sets the state of an entity.

(Irrelevant) #4

In the shader manual, under “Specific Shader Keywords” / “surfaceparm <parm>”:

4.8.11 nodraw
A texture marked with nodraw will not visually appear in the game world. Most often used for triggers, clip brushes, origin brushes, and so on.

This does not seem to work in my experiments with it. However, “surfaceparm nonopaque” apparently does what is described here.

(MadJack) #5

the harc of mg42 has to be half, but not lower than 45degrees, of what you want. Not any degrees. and the .def file says default of 115 degrees when in reality it’s 57.5 degrees (from the angle key set in the entity).

Ex: if you want your mg42 to make 180 degrees, in harc you put: 90. So if your angle on the MG42 ent is 360, the mg42 will be going 90 degrees to the left and to the right.

(=ds=bart) #6

FIXME: name == NULL || strlen(name) == 0 in QERApp_Shader_ForName wath is this dunno wath to do .

(Vitriol) #7

you get it from having a constructable command post. i dont know what it is, but it doesnt seem to hurt anything.

(onu123) #8

12:2: parse error at ‘(’: expected ‘#quake3-primitive
brush 0: parse error //brush numbers can be differing
entity 0: parse error //entity is always 0
map load timer: 0.02 second(s) elapsed
— LoadMapFile —
C:/Documents and Settings/—/
0 primitive
0 entities

A radiant error!?
with ALL of .map files, witch have been downaloaded or have been in computer before.

What is the problem?

(kamikazee) #9

Does it do the same with

(Nail) #10

don’t all your files have to be in actual game folders, not on desktop ?

btw, nice revive

(onu123) #11

I guess not… Example is a prefab… and it shouldn’t matter if all needed files are in one folder. iT must be a radiant error, ill try everything =)

(onu123) #12

Can’t anyone help? Noone knows what the HELL is the problem with my Radiant!?
Still all 0 primitive 0 entities…

Well there are some slight differneces from the last one…

Open file C:/… .map for read…success
1292:69: parse error at ‘1.#QNAN’: expected ‘#number
brush 106: parse error
entity 0: parse error
map load timer: 0.10 second(s) elapsed
— LoadMapFile —
0 primitive
0 entities

Sorry for double post, but had to =).

(nUllSkillZ) #13

Have you tried as suggested by kamikazee?
And you should try to put the maps in the maps folder.

(Diego) #14

Why not try reinstalling radient.

(onu123) #15

i have tried both,and well my 1. problemic post told that ALL of .map files, witch have been downloaded or have been in computer before. (won’t work)

Ive installed it (even deleted everything that includes radiants name)
And goldrush doesn’t work.
But the problem starts at some point… i made my newest mapat first it was ok, but then suddenlly it got the same problem.

(zstarsales04) #16

Hello, everybody, I am new here. Here is something might be helpful for (many movies to download)

(ballking) #17

your post is very useful for me,you will get good grades!

(WuTangH) #18

yo, dont u know why my gtk 1.5 crash after start?.. crash with “Dont Send” button i mean… o.O

(Mateos) #19
  1. Hello

  2. Search for you issue, then if nothing make a thread for your problem.

  3. Give more detail

  4. Don’t bump sticky resources threads please _

(Mateos) #20

Well, I think the following would be well placed here.

If you get a safe_malloc fail during the Light stage, at SetupTraceNode step, this is probably due to a _blocksize 0, or maybe just a custom one…

Tested here.