DirtyBomb worked until recent update...


(Quinn-san) #1

Hey guys, hoping someone can help.

I’ve played Dirty bomb for a year+ now and have never had ANY issues running the game until the most recent update on the 19th April, 2018.

Now I get the error below before the game fails to start-up:
ShooterGame-Win64_Shipping.exe
The application was unable to start correctly (0xc000007b).

I’ve seen some people run that file as admin at it works, not the case for me.
Any ideas? Ohh, I run Windows 7 - 64bit.

Thanks in advance.


(dududud) #2

Installed the game for the first time yesterday(19th April) and I get the same error too.


(Kirays) #3

Hi there.

Verify your Dirty Bomb game files as seen here:

https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335

Navigate to the following folder:

C:\Program Files (x86)\Steam\steamapps\common\Dirty Bomb\_CommonRedist

From there please attempt to reinstall DirectX and all vcredist.


(Quinn-san) #4

Thanks for the info Klrays but ‘verify integrity of game files’ shows ‘All files successfully validated’. Reinstalled both DirectX and Vcredist and still get the same issue. The game doesnt work anymore after the 19th April update.


(henki000) #5

Update graphics drivers, if available
Re-install .NET framework
Run sfc /scannow in cmd (checks windows for problems, automatically tries fix)
Run chkdsk c: /f (checks hard drive, assuming you have installed Dirty Bomb to C drive and tries to fix it)