DB crashes 50% of the time a match ends


(STARRYSOCK) #1

DB has always crashed a lot on me, but this one is new, and it happens constantly. Anyone else experiencing this or is it just me?
Especially annoying now that we get bonuses for staying after the match, but whatever…


(GatoCommodore) #2

i get these crashes since i turn on the Dx11 beta thingy


(Teflon Love) #3

I get them since the switch to 64 bit.


([ *O.C.B.* ] Wildcard) #4

@GatoCommodore said:
i get these crashes since i turn on the Dx11 beta thingy

Weird, I stopped getting crashes when I launched it using the Dx11 beta, you have to select it via the steam front-end to get to it or it launches the older Dx9 version; however if I try to run it in Dx9 mode, by just launching it normally, with the preferred mode in my video settings being on Dx11 at the same time I crash after every match fairly consistently. They didn’t make it very intuitive though I’ll admit, for your default rendering mode to be Dx11 you can’t use shortcuts or it launches with Dx9.


(henki000) #5

No crashes since last summer ranked. But I can imagine, it’s pretty bad if this kind of thing happens. Should be prioritised promptly.

Send ticket to support. Could be 100 reasons, why this occurs.

Look your crash reports/logs for more information:
…\Documents\My Games\UnrealEngine3\ShooterGame\Logs


(Ptiloui) #6

I got crashs too with DX11. Once when trying to join a server, other times at the end of a match, be it when returning to lobby or leaving it.


(Mc1412013) #7

cant even get dx 11 to work on my pc
restarted 20 times tried the -dx11 in properties i saw in the steam forums


(x3mytiz) #8


Courtesy of @Wo1ven


(Teflon Love) #9

@henki000 said:
Send ticket to support. Could be 100 reasons, why this occurs.

I doubt that’s necessary. SD added a nifty crash reporter that automatically sends whatever information they need using the interwebs. Probably their database is already running out of space.


(FalC_16) #10

Can confirm. I play DB since Jun 2015 and it never crashed. After turning on dx11 it crashes pretty much randomly.


(Kirays) #11

The only issue I am experiencing is the game hanging when I alt-tab during the map loading using DX11, apart from that everything is running fine on my end. I suspect the crashes have something to do with Nvidia’s broken drivers, I’m currently on 375.70 and it’s all good there.


(Mc1412013) #12

@teflonlove said:

@henki000 said:
Send ticket to support. Could be 100 reasons, why this occurs.

I doubt that’s necessary. SD added a nifty crash reporter that automatically sends whatever information they need using the interwebs. Probably their database is already running out of space.

This is the explanation for the lag in game. the same game servers host the database for the tickets. The high volume of crash reports are tying up system resources lol


(Teflon Love) #13

@Kirays said:
I suspect the crashes have something to do with Nvidia’s broken drivers, I’m currently on 375.70 and it’s all good there.

I’m on an ATI R260 (or something), so either their drivers are broken too or it is something else.


(STARRYSOCK) #14

@Kirays said:
The only issue I am experiencing is the game hanging when I alt-tab during the map loading using DX11, apart from that everything is running fine on my end. I suspect the crashes have something to do with Nvidia’s broken drivers, I’m currently on 375.70 and it’s all good there.

DB has always freaked out whenever I tried to alt-tab, but maybe I’ll try updating nvidia’s driver anyways. I was on 391.35, updating it to the latest one now. Worth a try at least, lol


(Kirays) #15

A few months ago I was experiencing heavy fps drops after a few alt-tabs across all games. I couldn’t figure out the reason for the life of me, it was driving me nuts. Initially I thought the windows fall creators update was causing the issue since that’s when it started, however it turned out the issue was caused by the new drivers so instead of updating you should try the exact opposite, downgrade. :slight_smile:


(STARRYSOCK) #16

@Kirays said:
A few months ago I was experiencing heavy fps drops after a few alt-tabs across all games. I couldn’t figure out the reason for the life of me, it was driving me nuts. Initially I thought the windows fall creators update was causing the issue since that’s when it started, however it turned out the issue was caused by the new drivers so instead of updating you should try the exact opposite, downgrade. :slight_smile:

Hmm, DB has always lagged after I alt-tabbed, but I’ll try that once I can get in game.
Only problem is some of my other games that don’t play nice with the older drivers, lol

Still though, thanks for the tip!


(Mc1412013) #17

@STARRYSOCK said:

@Kirays said:
A few months ago I was experiencing heavy fps drops after a few alt-tabs across all games. I couldn’t figure out the reason for the life of me, it was driving me nuts. Initially I thought the windows fall creators update was causing the issue since that’s when it started, however it turned out the issue was caused by the new drivers so instead of updating you should try the exact opposite, downgrade. :slight_smile:

Hmm, DB has always lagged after I alt-tabbed, but I’ll try that once I can get in game.
Only problem is some of my other games that don’t play nice with the older drivers, lol

Still though, thanks for the tip!

Alt tab lags horribly for 5 seconds then smooths out


(Ptiloui) #18

Setting in borderless windowed mode solved any alt-tabbing related issue i had.


(Kirays) #19

That does have the negative downside of experiencing increased input lag, though.


(Ptiloui) #20

@Kirays said:
That does have the negative downside of experiencing increased input lag, though.

Mmmhh, I might try again without it then.