CRASH: Random crashes throughout the whole game

(Izeyash) #1

Hi there.

I am very desperate. I searched on all the internet for a solution for my problem, but nothing worked.

When I try to launch the game, everything is fine. Until I get to the character selection screen. Sometimes I get to choose a server for online multiplayer, sometimes it freezes/crashes right at the screen in the beginning.

All my pc specs are ENOUGH to play Brink on a high quality: I already played the game 6 hours where it did NOT crash all the time. But it seems that my graphics card is the only problem, or should I rather say the game has a problem with the card?

I have a ATI Radeon HD 4890 installed in my system and got the latest driver (13.4 Beta).

I tried the following (I might have forgotten something to list):

-verify game cache via steam (It says EVERYTIME I do that that 1 file is missing which will be reaquired, like 10 times in a row if I verify the game cache 10 times in a row)
-I searched like hell for the bloody 11.5a hotfix on the internet, but didn’t find anything
-I enabled ingame console and used the command “r_shadows 0” without the quotes which didn’t help
-I reinstalled the game like 20 times
-I put all the settings on the lowest possible

Furthermore, I saw that you recommend the driver 11.10 (released October 2011). But Brink is not the only game I play. I refuse to install OLD drivers to play ONE game when the other games I play require the LATEST drivers.

Also, I found this link for the 11.5a HOTFIX of AMD:

which refers me automatically refers me to this page:

I need the help urgently cause I know how awesome this game is. There MUST be a way playing the game with LATEST drivers.

(njezic) #2

Uninstall the game (delete local contents on steam) and then download all and install again.
Game for a long time working good with the ATI drivers with no problems so you don’t need older drivers.

I think, only problem is the correct installation…

(Izeyash) #3

Does not work, as I said. Besides, you told me that in steam already, and even there I told you, it does not work.

So guys, PLEASE do something.

The problem still exists. Is this community actually this lazy to help a guy who REALLY wants to play this game?
I am disappointed,

(Izeyash) #4

BUMPING the hell out of it.

(Izeyash) #5

I am disappointed of this game and this community. Better didn’t buy it. I will also prevent others from buying it now.

(Nail) #6

go bitch at Bethesda, it’s their game and they’ve never done anything for it