Compiling sky light for a Q3 map with GTKradiant

(Captaintoottoot) #1

How do I get GTKradiant 1.5 to compile light using sky shaders light?
How do I customize the build options in GTKRadiant 1.6.3?

I’ve used gtkradiant 1.5 for the longest with Warsow, Doom3, and Quake 4. Now when using it with Quake 3 it will create all the other lights on the map but it doesn’t generate the shadows from a sky shader. Some of the threads I’ve already looked through to no avail are:

I compiled the map in gtkradiant 1.6.3 and it worked but the problem is that I need to adjust the compile options and there is no way to do so with that version. There is no longer a ‘customize’ button in the build menu and I found that feature in the ‘project settings’ option!? Then when I go to change a line nothing actually changes after I hit ok. All I can do is remove lines and I can’t add any. I don’t even know what physical file this is being stored at to notepadify it.

(Captaintoottoot) #2

I’m so damn awesome. I found the solution before the forum approved my post. Now I shall respond to my past not-as-awesome self with the solution:

Reinstall gtkradiant 1.5 for starters. Then check the file in the games dir of gtkradiant 1.5 and set “enginepath_win32” to the new location you moved the game to rather than the default program files location. For whatever reason radiant doesn’t change this value even when setting the game path from the menu so it must be done manually. It couldn’t find the shader or something.

Oh and past self while I’ve got your ear, stay away from a girl named Ashley, she will **** your mind up. That is all.