Compiling problem

(stealth6) #1

When I press compile
I do the one starting with simulte old style

I get this message 4 times and then the dos window closes

Writing the compile script to 'C:/Documents and Settings/Conrad Young/Application Data/RadiantSettings/1.5.0/qe3bsp.bat'
The build output will be saved in 'C:/Documents and Settings/Conrad Young/Application Data/RadiantSettings/1.5.0/junk.txt'

Why cant I compile?

I’ve looked for the junk.txt file but I cant find it in the place that is listed here

I’m using GTKradiant 1.5.0

(TNR360) #2

any errors?

(]UBC[ McNite) #3

I assume you r trying to compile with Radiant? Get Q3map2Build, its an external compile program and much better. Enable compile loggin with it, then you ll get logged what your problems are too.

(stealth6) #4

ok thank you I tried my map but there was something wrong with my flag I didn’t link it tothe script or something like that so trying to figure that out now

EDIT: just forgot to give the flag a scriptname DOH! hehe
but just tried my map its ok, but still lots of work to do (cant get off at top of ladder, windows dont break, can still walk through trees)

but thats good, at east I’m getting somewhere =D

TYVM for ur help

(TNR360) #5

well it may be usefull at times compiling with radiant incase an origin gets mssed up and you need to find the entity 10mins flying off the grid following that frustrating red line :shock:

(-SSF-Sage) #6

Make the ladder texture at the same level as the floor you are climbing to (or the ladder itself). For example window:
key value

classname Func_explosive
health 30 //brakes after 30 hp damage
mass 750
spawnflags 16
type glass

And for the tree probleme: trees are models and models are usually nonsolid (can walk trough). So you have to make a brush that lines about the trees body (not the trees leafs) and give it a texture for example clipweap. Clipweap stops the bullets and players, but won’t be seen. Clip if you don’t want to block the bullets.

(stealth6) #7

Thanks for tips,
I would compile more often, but I’m only making a small map so…

As for the ladders I can climb up them, but the end at a roof under a ±30degree angle so you kinda bounce at the top, I’m going to try and make the ladder texture a bit taller so maybe you kan get on roof properly

As for windows I made 1 and then copied it, but that went wrong somewhere ob cause I could see that the window had life, but I could destroy it…

For the doors it did work (make 1 and then copy)

(-SSF-Sage) #8

You can copy it. But you have to make sure you copy both, the brush AND THE entity, otherwise you will end up when you break some, all will break. If you make ladder texture too long (not really about few units, but if it’s like 8 or more) it will make you “stuck” when you come from the other side. I didn’t quite get what you said, but if you make another brush with ladder and rotate it? If it goes like, but in this case it might not be necessery if the angle is not too much, in other word it won’t slide you down, can walk on it.


As for windows I made 1 and then copied it, but that went wrong somewhere ob cause I could see that the window had life, but I could destroy it…

Do you mean that you could not destroy it and you had the hint? Check out how much is the health for the explosive. Maybe you had too big value. As I told you value 10 is the same as 10 hps in game.

(stealth6) #9

yea I got that I didnt tick the box use shader and that gave problems obviously

but that is fixed Now I was trying to create fog in specific places, but just getting solid brushes, as for the ladders making them lonnger idnt work so i tried to make it 1block in grid 2 larger in width cause it went stright through the roof well its hard to explain but i’ll tell you if it worked

Added lights cause could see alot lol and gonna test again now

EDIT: just tested it lights work yay! and ladders do 2 now the roof was just blocking it so thats fixed, but the fog isnt it’s just a solid wall :frowning:
so now trying to fix fog