Bad Fps and constant stuttering

(Gordyne) #1

Coming back to this game after 7 or 8 months I was shocked to see how performance got worse.

I used to run the game smoothly at constant 60 fps. Now even at medium graphic settings I get constant stutters and unstable fps.

I can run games like The Witcher 3 just fine, so it’s not on my end.

Already deleted the Config folder. Didn’t help.


I5 3250k
Gtx 970
8GB Ram DDR3 dual channel

(Mustang) #2

Probably not the case, but have you got any joysticks/controllers/wheels/etc plugged in?

I have a massive drop in FPS after a couple of minutes if I have any of these connected.

(Gordyne) #3

Nope, I don’t own any of those.

(Mustang) #4

Oh well, worth a try.

(Gordyne) #5

Hmm. I might have fixed it by turning dynamic resolution off.

After deleting config folder and chosing “High” settings, Dynamic Resolution was set to ON again.

I’ll keep playing to see if the issue doesn’t come back…


(Mc1412013) #6

I notice castle kills my fps randomly havent noticed i any other map

(K1X455) #7

I also complained about this FPS drop… I used to get FPS cap @ 180fps now it goes down as low as 30fps on Vault.


I’ve just tried to look up the specs of this processor - Intel ARK doesn’t recognise an i5-3250k in their database. There is an i3-3250 if that is what you are referring to?

If you have ever manually edited your Dirty Bomb .ini files, deleting them and allowing DB to create fresh ones can solve a great deal of problems between updates. We generally don’t recommend editing them for this reason.

That said, here’s a few other things you can try…

First, you may want to head into “Power Options” and select “High performance” from the plans listed - if your CPU is being power throttled, this should eliminate that as a potential bottleneck. If you have a third-generation Intel i-series, you’ll want to squeeze out every ounce of power you can from it.

You will also want to make sure you have the latest GeForce drivers for your GTX970 - this card is more than capable of running Dirty Bomb (I used to have this card myself).

If those quick tips don’t improve things, it would be really helpful if you could submit a support ticket and send us a copy of your DxDiag so we can look into things further.

(Mc1412013) #9

I think this fps issue started around when they went 64 bit and dx11

All i know is im not thermal throttling . Im on water cooling and gpu never goes past 60-61c and cpu goes 55c max at 85f ambient temp

(RageSmirk) #10

Hi, I also have this problem in Castle map.
CPU: Ryzen 5 2600X
RAM: 16GB DDR4 2133MHz
GPU: GTX 1060 3GB
1680x1050 resolution

I think maybe it’s related to my memory being a bit slow?
Whatever they do at Castle map, maybe they do memory intensive work

(RageSmirk) #11

Can you look into what I said?
Castle map needs memory speed to be more than 2133MHz ??

(Gordyne) #12

I I read it wrong. My processor is I5 3570k.
I can play at constant 60 fps after deleting Config folder and disabling dynamic resolution

Thanks for the help!

(Gordyne) #13

I never had problems with castle map. And my memory is a bit “old” 1000 “something” Mhz

(RageSmirk) #14

how did you disable dynamic resolution?

(Gordyne) #15

Well, I just went in the video options and disabled it. It’s under the resolution option

Might not be available for all graphic cards, maybe?