Help on skybox

(Paashaas) #1

trying to create a skybox for q3/ql

everything works fine but I cant seem to force nopicmip on it like I can with normal textures.

anyone got a soluion for this?

my code :

qer_editorimage env/mp_sincity/sincity_ft.tga
surfaceparm noimpact
surfaceparm nolightmap
q3map_lightsubdivide 256
q3map_surfacelight 100
surfaceparm sky
q3map_sun 1 1 1 100 0 90
skyparms env/mp_sincity/sincity - -

whatever I try failes o work. its just like it seems nopicmip doesn’t work for skyboxes?

(WuTangH) #2

Hey there,

Maybe you can try to add noMipMaps parameter, too.

Also, here’s one sky shader with nopicmip, as an example… If nothing helps, maybe just edit this one as you need: